Arduino can't upload bootloader to AtMega328p chip

Hello,
I have a problem
Here is how it goes
I bought an AtMega328p chip from here: 1PCS ATMEGA328 ATMEGA328P ATMEGA328P AU ATMEGA328P UATMEL TQFP32 QFP MEGA328 AU SMD new and original|Integrated Circuits| - AliExpress
I want to upload bootloader to it
But every method i try, I get errors
A lot of DIFFERENT errors

One time it says it’s not in sync
One time it says that programmer is not responding.
I tried both Arduino 1.0.1 methods and Arduino 1.8.12
I’m using Arduino Mega as programmer (ISP).
Wired everything on Arduino Mega through ICSP port, and at my PCB as intended: EasyEDA(Standard) - A Simple and Powerful Electronic Circuit Design Tool
However, I forgot to wire MISO, so i had to wire it up at NRF24L01 part

I soldered everything without any shorts.

Here is example of one error:

It just spits out random HEX values, not always 0x000000
One time it spit out this: expected: 0x14, resp: 0x14

Tried to use a lot of tutorials but none worked for me…

Sometimes it says that i can use -F to override a check
But I don’t know where I can write it?
Anybody knows what’s happening?

Thank you so much
-mytja

Is the nRF connected while you try to burn the boot loader? If yes, that might very well interfere with the upload.

Sorry, battling with your easyeda (probably not your fault).

NRF24L01 is not connected (since, I haven't recieved it yet)

Components aren't getting warm when i connect them to power, which means, it's not a short circuit.
Here are some pictures of PCB and connections: