Arduino Chip Boot Problem

I have looked in the "Boot up" forum and cannot find the answer to this question. Any help appreciated. (1) With my Arduino UNO and the original Atmega chip, when I program it, unplug it from the USP cord, then plug it into a power supply it runs the installed program fine. (2) I bought some Atmega chips to use that will not do this. They run the installed program fine right after I install the program. But if I plug the arduino into a power supply, they will not run the program anymore. The program will not run when I plug it back into the USB port either. The Atmega chips I bought apparently have the bootloader program installed on the chip already because the place I bought them from says it is pre-installed, so I assume this is not the problem. In a nutshell, the original Atmega chip will reboot and run the installed software but the purchased chips won't. The purchased chips say "Atmega" on them so I assume they are the correct chips. Any help here? Thanks, Dave

You are plugging your chips into the Arduino UNO, in place of the original processor? You are uploading to the chips normally, the same as you do with the original chip? If so you definitely have a boot loader on the new chips and I don't know why the sketch does not run again when power is applied.

Thanks for the response. I just cannot figure this out. I bought 5 Atmega chips and when I had the problem with the first one, I thought it might just be a fluke with that chip. But all of the purchased chips do this same thing. The Original always works perfect. Dave

Sounds like something very strange in the bootloader that came installed on those chips. If you have another UNO or earlier Arduino you can use the omniloader sketch to use one Arduino as a programmer to write a fresh bootloader on the other Arduino.

If you don't have a second Arduino you can get a USBasp programmer from eBay for under $5 (including shipping from China!). Then you can program fresh bootloaders on chips in your Arduino.

Here is another clue I just noticed while checking it out. With the original chip, when I plug the board into a power supply, the yellow LED on the board by the ground pin and looks like it is labled "L" stays lit solid. When I use the other chips when I reboot the LED flashes like three times (very fast) pauses and flashes three times agian. I do have another UNO Board. Can you tell me where to locate the instructions to try and reprogram the bootloader?

Thanks so much for the info. One last question, The page with the hardware wireing instructions does not seem to point where the "Sketch" is for my UNO. Do you know where that is? Dave

oops, After I read the instruction page a few times, I understood the procedure. Wii try tonight.

I tried the ISP bootloader using two UNOs but kept getting an error. I then used the setup using one Arduino UNO and a Breadboard (the setup that uses the 16 mh crystal. It worked perfect. I installed the boot programs to all 5 chips and they now work correctly (when I hook the board up to a power supply, they boot and run the programs). Thanks for the help, I can’t imagine why the original bootloader installed when I bought the chips did not work.