Arduino-cli Error getting board list

Hi,
Arduino-cli is new to me. I'm using Linux Ubuntu CLI to run my project. I can not list my board. arduino-cli core list command returns empty.

arduino-cli board list
Error detecting boards: Error getting board list: [listing ports from discovery builtin:serial-discovery: command failed: Error while enumerating serial ports: open /sys/devices/pci0000:00/0000:00:1d.0/usb1/1-1/1-1.1/idVendor: permission denied]

I installed the arduino-cli in the following order

  1. I installed arduino-cli using the curl -fsSL https://raw.githubusercontent.com/arduino/arduino-cli/master/install.sh | sh command.
  2. Then I run arduino-cli core update-index
  3. Then I try to list my board, it did not work.

I tried adding dilout group to the user, but no luck.

Note: Arduino IDE works fine, I can connect and upload sketch without any trouble.

Thank you for your time.

Hi @karthikeyan_krishnanandan. I see someone has reported a similar error to the Arduino CLI developers here:

If you have a GitHub account, I recommend subscribing to that issue so that you will get notifications of any updates that are posted there.