Arduino CLI error

Hello everyone, I am a beginner in Arduino CLI. I already have the executable and when I try even the simplest command like board details, I am getting an error saying

"Error getting board details: creating instance: downloading builtin:ctags@5.8-arduino11 tool: Get "https://downloads.arduino.cc/tools/ctags-5.8-arduino11-pm-x86_64-pc-linux-gnu.tar.bz2": dial tcp: lookup downloads.arduino.cc: Temporary failure in name resolution"

If anybody has got this error before and knows how to resolve, please help....

Your post was MOVED to its current location as it is more suitable.

Could you also take a few moments to Learn How To Use The Forum.

Other general help and troubleshooting advice can be found here.
It will help you get the best out of the forum in the future.

Hi @joagleena. Are you still having the problem if you try it again now? I am wondering if it was a transient error caused by a momentary outage of the download server.

I just gave it a try here and had no problems downloading that file.

Hello,

Yes, I tried it just now once agian, I am facing same issue

What happens if you click on this link here on the forum?:
https://downloads.arduino.cc/tools/ctags-5.8-arduino11-pm-x86_64-pc-linux-gnu.tar.bz2

It should start a download of the file ctags-5.8-arduino11-pm-x86_64-pc-linux-gnu.tar.bz2.

Hello Pert, thanks for your prompt response
Yes, the file is downloaded but I am working with remote desktop, I copied the file there and tried to implement cli commands, still getting same error !

The ctags file from inside that .tar.bz2 download needs to be located at the following path:

~/.arduino15/packages/builtin/tools/ctags/5.8-arduino11/ctags

Did you copy it there?

Hi, Thanks a lot, that worked !

1 Like

You're welcome. I'm glad to hear it's working now. Enjoy!
Per

1 Like