Arduino-cli problems on linux

Hello friends.

i'm getting this boring error message and it does not really make sense, but I think they might be due to Python

carsten@debian-HP:~/sketchbook/ESP32$ arduino-cli version
Error reading config file: While parsing config: yaml: line 2: did not find expected key
ERRO[0000] Error reading config file: While parsing config: yaml: line 2: did not find expected key
arduino-cli alpha Version: 0.16.0 Commit: c977a238 Date: 2021-02-15T09:30:01Z

python on computer is:
Python 3.7.3 (default, Jul 25 2020, 13:03:44)
[GCC 8.3.0] on linux

Hi @carstenF. This error indicates your arduino-cli.yaml configuration file has some invalid YAML syntax in it.

It is not related in any way to Python.

I can help you to fix this, but I'll need a little more information first. Please post the full output from running this command:

arduino-cli config dump -v

it took some time, I ended up destroying my linux installation, but now it is fixed again :slight_smile: but it unfortunately did not help my problem. arduino-cli config dump -v gave the following result
INFO[0000] Using config file: /home/carsten/sketchbook/arduino-cli.yaml
INFO[0000] arduino-cli version 0.16.1
INFO[0000] Executing arduino config dump
board_manager:
additional_urls:

Please post the output from this command:

cat /home/carsten/sketchbook/arduino-cli.yaml

board_manager:
additional_urls:

daemon:
port: “50051”
directories:
data: /home/carsten/.arduino15
downloads: /home/carsten/.arduino15/staging
user: /home/carsten/Arduino
library:
enable_unsafe_install: false
logging:
file: “”
format: text
level: info
metrics:
addr: :9090
enabled: true
sketch:
always_export_binaries: false

OK, I’m still not managing to spot the problem. However, I am able to reproduce this error on my own computer by intentionally using specific forms of invalid YAML in my configuration file, so I think I know what to look for.

Please attach the arduino-cli.yaml file in a reply here.

Since the way to do this isn’t terribly intuitive, I’ll provide instructions. I hope you’ll forgive me if you already know this:

  • Click the “Reply” button here on the forum.
  • Click the “Attachments and other options” link.
  • Click the “Choose files” button.
  • Select the file at /home/carsten/sketchbook/arduino-cli.yaml (AKA ~/sketchbook/arduino-cli.yaml).
  • Click the “Open” button".
  • Put some text in the reply message field so the forum will allow you to post.
  • Click the “Post” button.

the original error is gone, :slight_smile:

but now I have another problem,

started a new thread with this problem otherwise I think it will be a mess

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.