arduino clone with motor control problem

Hi there,

I have problem with an interesting application of Arduinos in a novel building control system.

The system basically controls 2 motors using MOSFETS, reads two external sensors, can have its ID set using 7 dip switches and communicates over RS485 with a master unit.

I prototyped the system with an Arduino Duemilanove and Arduino Pro and it worked fine. I has gone to a manufacturing firm who have basically cloned an Ardunio pro onto the main PCB. They reckon that have got a boot loader on it but keep getting the common: avrdude: 'stk500_recv(): programmer is not responding' error when attempting to programme the board. The happens when even attempting to load the simplest 'blink' programme. They are programming the board using WinXP and Vista, Ardunio IDE 017 & 018 using a FTDI TTL-232R-3V3 cable.

The dxf file of the circuit is here: ATMEGA168-20AU

We are planning to open source hardware and software once the bugs ironed out. I have used Ardunios in many creative projects over the years but this custom stuff is beyond my understanding.

Help would be very much appreciated!


How are you trying to programme it. That circuit has no input buffers so you can't just plug it in to an RS232 connector from a USB to Serial lead.

Have you got the TX and RX connections right. The arduino TX is an output make sure it is connected to an input on your programmer, if in doubt check which is the output with an oscilloscope.

You have not used an on board reset switch, this is handy for programming if the auto reset doesn't work of the is not supported by your USB / serial interface.

Finally you might have to change the auto reset capacitor to 1uF.

They reckon that have got a boot loader on it

  1. Have they tried their programming environment with an actual, pre-bootloaded, real Arduino 2009 board?

  2. Have they tried swapping the bad ATMega with the one on the known good board (assuming it is swapable, of course).

Your saying "they reckon" throws a big red flag up for me; I am sure it could be other issues, but this one would be among the first things I would check.

You didn't mention anything about how they got the bootloader (or if they put one on) onto the chips or such; with the parts you mention they are programming the board with, I don't think you can get it on that way. Where did they get the chips? Did you supply them with the pre-bootloaded chips? Did they get them bare from Atmel? Did they get them from another source?


Many thanks cr0sh and Mike. Very much appreciated. I have forwarded the thoughts to the manufacturers. They loaded the boot loader with AVRStudio apparently having had problems with the Ardunino IDE. The chips they are using are surface mount, so obviously not swappable. I am not sure where they got them. I am pretty sure they did not come pre boot loaded.

We were indeed trying to program it with a USB lead with the FTDI chip in it. No input buffer could well be the problem. I was under the impression they had basically cloned an Arduino Pro which is what I used in the test units.

I'll revert as soon as I have heard back.

thanks again