Arduino Community Logo

..annunciato alla MakerFaire a New York da Massimo Banzi; qui qualche info in più:

Mi piace :slight_smile: però avrei messo più colori.

Ma avete provato a scaricarlo ??? :astonished:

Vi scarica un PDF che, almeno su Mac, risulta corrotto. Dato in pasto ad un programma di "pdf repair" tira fuori questa serie di errori :

Open file.
0x8041010B - E - The 'xref' keyword was not found or the xref table is malformed.
    - File: C:\Windows\TEMP\tmpF76C.tmp
Recover XREF table.
0x80410306 - E - The "Length" key of the stream object is wrong.
    - Object No.: 5
    - File: C:\Windows\TEMP\tmpF76C.tmp
0x80410307 - E - The "endstream" keyword is missing.
    - Object No.: 5
    - File: C:\Windows\TEMP\tmpF76C.tmp
Analyze Objects.
0x80410306 - E - The "Length" key of the stream object is wrong.
    - Object No.: 5
    - File: C:\Windows\TEMP\tmpF76C.tmp
0x80410307 - E - The "endstream" keyword is missing.
    - Object No.: 5
    - File: C:\Windows\TEMP\tmpF76C.tmp
Analyze Outlines.
Analyze Pages.
0x80410113 - E - The file is corrupt and cannot be repaired. Some of the contents can possibly be recovered.
    - Page No.: 1
    - File: C:\Windows\TEMP\tmpF76C.tmp
Recover Pages.
Save output file.
0x80410306 - E - The "Length" key of the stream object is wrong.
    - Object No.: 5
    - Page No.: 1
    - File: C:\Windows\TEMP\tmpF76C.tmp
0x80410307 - E - The "endstream" keyword is missing.
    - Object No.: 5
    - Page No.: 1
    - File: C:\Windows\TEMP\tmpF76C.tmp
Close file.

... ma comunque alla fine lo ripara. Il guaio è che se lo si apre in Photoshop ... NON ha layers e quindi ... come cavolo si fa ad eliminare la loro scritta ed a mettere il proprio logo ??? ... taglia e incolla ??? 'na schifezza ]:smiley:

Qualcuno è riuscito a scaricare una versione NON corrotta ??? Ci solo layers modificabili ???

Altrimenti hanno messo in linea qualche cosa veramente fatta male !!!

Guglielmo

Va bé … per chi lo vuole, ho tagliato via la loro scritta e l’ho riaggiunta il un layer di tipo “testo”. Salvato in formato psd apribile con Photoshop :wink:

Buon divertimento ora a farvi il vostro personalizzato :slight_smile:

Guglielmo

Logo_RGB.psd (859 KB)

Io la versione CMYK la scarico correttamente. In effetti su Photoshop (CS2) non risultano altri layer :(. Immagino che sia una specie di "beta" ancora da affinare :smiley:

cece99:
Io la versione CMYK la scarico correttamente.

VERO ! E' solo la versione RGB corrotta ... comunque sopra ho messo una versione ... psd :grin:

Guglielmo

gpb01:
VERO ! E' solo la versione RGB corrotta ... comunque sopra ho messo una versione ... psd :grin:

Ho provato adesso a scaricare tutte e due le versione e non riscontro nessun problema aprendole con foxit reader.

astrobeed:
...
Ho provato adesso a scaricare tutte e due le versione e non riscontro nessun problema aprendole con foxit reader.

... neanche io se uso "Skim" ... ma prova con Adobe Acrobat o con Adobe Photoshop ... e mi dirai :wink:

Skim è più tollerante e riesce a ricostruire le informazioni errate, così immagino faccia "foxit reader" ...
... il problema è però poi esportare in un formato apribile da PS (... non so foxit, Skim non lo fa).

Guglielmo

Ma chi NON ha Adobe come fa ad usare questo logo?
Io ho aperto la versione CMYK con Gimp solo che mi ritrovo con un logo che non è vettoriale per cui ingrandolo viene tutto sgranato! Sbaglio io?

@leo72
io ho provato ad importarlo su Inkscape e si riesce a gestire bene senza perdere di qualità.

leo72:
Ma chi NON ha Adobe come fa ad usare questo logo?
Io ho aperto la versione CMYK con Gimp solo che mi ritrovo con un logo che non è vettoriale per cui ingrandolo viene tutto sgranato! Sbaglio io?

Scusa Leo, ma Gimp non apre direttamente i .psd ???

Mi sembra di SI, per cui QUI l'ho messo io in .psd :wink:

Guglielmo

x iscrizione

..io me lo son importato su inkscape, e rimosso il testo.
Il file vettoriale è community_logo_emty.svg

Poi sulla base di questo ho inserito del testo di prova (lo stesso testo che c'era prima)
Il carattere che ho usato è il DejaVu Sans Mono 36.
Per i colori ho usato la palette pubblicata sullla pagina linkata nel primo post.
il file vettoriale è community_logo_test.svg

@gpb01

Scusa Leo, ma Gimp non apre direttamente i .psd ???

ti rispondo pure io: gimp apre i .psd, ma come immagine (almeno, non so se c'è procedura per importarli in altro modo), quindi ingrandendo si perde qualità.
Questo significa non avere la libertà e le potenzialità che si ha con un vettoriale - certo dipende da chi lo usa, e come lo usa.

community_logo_empty.svg|0x0

community_logo_test.svg|0x0

pitusso:

Il file vettoriale è community_logo_emty.svg

… se deve essere VETTORIALE, che un VERO vettoriale sia !!! ]:smiley:

In allegato, vuoto e senza testo, la versione vettoriale del logo :wink:

Guglielmo

Arduino.ai (90 KB)

Arduino.svg

@gpb01

… se deve essere VETTORIALE, che un VERO vettoriale sia !!!

non colgo la sottile ironia :stuck_out_tongue: mi sembra che sul tuo file siano solo raggruppati gli elementi del logo… :grin:

EDIT
aprendolo con inkscape vedo pure dei difetti alla grafica (boh, cmq allego esempio)

Selection_070.png

pitusso:
...
non colgo la sottile ironia :stuck_out_tongue: mi sembra che sul tuo file siano solo raggruppati gli elementi del logo... :grin:

Ahahah ... veramente il tuo, aprendolo in Adobe Illustrator, me lo dava come un'unica immagine e non come elementi vettoriali separati ... è un problema di AI o era fatto proprio così ???

Il mio è la vettorializzazione di ogni elemento componente ... e dato che è fatta con un programmino automatico ... non dubito che ci siano delle imperfezioni ... del resto vettorizzare i singli elementi non è operazione banale :wink:

Comunque, a parte vari giochi che stiamo facendo, vanno bene TUTTI ... anche il bitmap RGB ... :grin: :grin: :grin:

Guglielmo

Ciao

Ahahah … veramente il tuo, aprendolo in Adobe Illustrator, me lo dava come un’unica immagine e non come elementi vettoriali separati … è un problema di AI o era fatto proprio così ???

su inkscape ho lasciato i singoli elementi del logo separati, sinceramente non son come venga importato un file .svg nativo inkscape su ai…

Il mio è la vettorializzazione di ogni elemento componente … e dato che è fatta con un programmino automatico … non dubito che ci siano delle imperfezioni … del resto vettorizzare i singli elementi non è operazione banale

ok, a me succede l stesso che succede a te: lo vedo come file unico.

Cmq su Inkscape, una volta importato il file .pdf originario, i singoli elementi del logo venivano riconosciuti senza dover fare altro (vedi esempio allegato di selezione elemento sul file su cui ho lavorato io).

Comunque, a parte vari giochi che stiamo facendo, vanno bene TUTTI … anche il bitmap RGB …

chiamali pure pipponi :grin:

Selection_071.png

bho... a me piace di più quello semplice tutto verde.

pitusso:
...
ok, a me succede l stesso che succede a te: lo vedo come file unico.
...

Allora,
mi sono scaricato inkskape per Mac e funziona come funziona a te ... il che è una cosa ben strana XD

Il mio, se lo apro con AI, mi fa vedere tutti i singoli elementi, mentre il tuo me lo fa vedere come un unico oggetto. Se invece uso inkskape ... esattamente l'opposto ... boh ... valli a capire 'sti programmi di grafica vettoriale :grin: :grin: :grin:

Comunque ... ora li abbiamo messi a disposizione in tutti i modi possibili, ognuno si scarica quello che più gli si adatta :wink:

Guglielmo

mi sono scaricato inkskape per Mac e funziona come funziona a te ... il che è una cosa ben strana

Il mio, se lo apro con AI, mi fa vedere tutti i singoli elementi, mentre il tuo me lo fa vedere come un unico oggetto. Se invece uso inkskape ... esattamente l'opposto ... boh ... valli a capire 'sti programmi di grafica vettoriale

son d'accordo. Pensavo ci fosse un qualche standard...

Comunque ... ora li abbiamo messi a disposizione in tutti i modi possibili, ognuno si scarica quello che più gli si adatta

+1