Arduino Compiles but Doesn't upload sketch

I was working on a project for hours and everything was working fine. Suddenly, the sketch would compile but not upload to the board. I tried the basic blinking example sketch but it still doesn’t upload. I am using the Nano 33 BLE and I have the library installed. I have the correct board and port selected, but still nothing. I have uninstalled the IDE and reinstalled multiple times and have restarted my computer and still it doesn’t upload. I am using IDE 1.8.13 and Windows 10. The code I get when the upload fails is below.

java.io.IOException: Cannot run program "___REMOVE___/bossac.exe": CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
	at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
	at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:129)
	at cc.arduino.packages.uploaders.SerialUploader.runCommand(SerialUploader.java:383)
	at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:197)
	at cc.arduino.UploaderUtils.upload(UploaderUtils.java:77)
	at processing.app.SketchController.upload(SketchController.java:732)
	at processing.app.SketchController.exportApplet(SketchController.java:703)
	at processing.app.Editor$UploadHandler.run(Editor.java:2055)
	at java.lang.Thread.run(Thread.java:748)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
	at java.lang.ProcessImpl.create(Native Method)
	at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
	at java.lang.ProcessImpl.start(ProcessImpl.java:137)
	at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
	... 9 more
An error occurred while uploading the sketch

Hi @gabv214. Please try this fix from the Arduino Help Center:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.