Arduino con piedini non attivi eroga corrente?

Salve a tutti, ho sui piedini del mio arduno dei transistor a cui è collegata l' alimentazione da 12 V e qualche led con una resistenza. Nel momento in cui un piedino è attivo i led si accendono correttamente nel modo giusto. Quando tutti i piedini sono settati su LOW l'arduino è come se mi erogasse una [u]piccola dose di corrente[/u] sui piedini 12 e 13, forse dovuta all'alimentazione da 12 volt sui transistor creando così un circuito e accendendo in piccola luminosità i led. Non trovo altre spiegazioni, ma soprattutto come posso evitare questo, è estremamente importante perchè quei led dovrebbero stare spenti, grazie in anticipo.

Hai provato con una resistenza di pull-down?

Ma i transistor sono npn o pnp?

Sono npn, come dovrei utilizzarla la resistenza pull-down? Il mio circuito è già stato stampato e risulterebbe difficile modificarlo

Prova a fare un collegamento volante con una resistenza da 10K ohm tra la base del transistor (o l'uscita dal piedino, se è più comodo) e GND.

Ne ho utilizzata una 2Kohm, precisamente seguendo questo schema: http://arduino.cc/forum/index.php/topic,146152.0.html figura 2 led in serie

GioJoker: Ne ho utilizzata una 2Kohm, precisamente seguendo questo schema: http://arduino.cc/forum/index.php/topic,146152.0.html figura 2 led in serie

Ciao sono PighiXXX, l'autore di quegli schemi. Quanti led hai messo in serie? Che transistor hai usato? La prima prova che puoi fare, a prescindere dalle risposte :D, è aumentare il valore della resistenza tra l'uscita del pin Arduino e la base del transistor. 6.8K per esempio.

Quale Arduino stai usando?

Fino alla Arduino UNO R2 sul pin 13 c'éra messo un LED con una resistenza da 500 OHM a massa. Quello poteva dare problemi ai circuiti collegati. Siccuramente non da problemi a un Transistore NON collegato. e poi dovrebbe dare questo efetto solo sul pin 13 e non sul pin 12. Che valore di resistenza base hai usato? Che transistor stai usando? Hai per caso invertito il collettore e emettitore dei transistori collegati al pin 12 e 13?

Ciao Uwe

GioJoker: Quando tutti i piedini sono settati su LOW

La domanda sembrerà stupida ma la faccio comunque: ti sei ricordato di attivare i pin come output?