Arduino Diecimila not loading sketch!!

My arduino isnt uploading sketches, though the power light is on. The Rx an Tx dont light up at all and I get this error:

avrdude: stk500_getsync() : not in sync: resp=0x00
avrdude: stk500_disable() : protocal error, expect=0x14, resp=0x51

Can someone please tell me what this means??!!

thanks

nigel

It means that something is not working with the link between the arduino and the computer. It could be a lot of things.

How are you sending to the arduino? Usb? FTDI cable?

Is anything else hooked up to digital pins 0 and 1?

Do you have to push the reset button on your type of arduino like board in order to get it to accept a new sketch? ( you do have to do that on some models)

Are you sure you are sending to the right serial port?

Is there something wrong with your cable?

You see.... lots of questions. You need to be extremely specific about your setup and what you've tried in order for people to help you narrow this down. This can be a really annoying problem.

Sorry I will try to be more specific.

It started when I plugged my arduino into a 9 volt wall wart. the black chip between the power jack and the ext / usb headers heated up so I unplugged it. I tried using the usb cable but when I plugged it in the power light only lit up for a second, then went out. I let it cool down for half an hour and when I plugged it in the power worked fine, but it wouldnt upload a schetch, it would just say the errors from the last post. I tried switching serial ports, switching usb plugs, resetting it, using external power, nothing seems to work. Sometimes when I try to upload a schetch the Rx light flickers, but only a little bit, but I tried it recently and I dont get anything. The computer seems to still recognize the arduino when I plug it in, because it makes that sound when you plug something into usb, so there is some kind of connection.

Hope this is enough detail for you to help me!!

Thanks a lot

Nigel

Well, unfortunately it seems like you've probably smoked the board somewhere. The computer will register a connection if the FTDI chip on the arduino is still working (at least for the most part.)

The black chip you are referring to would probably be the 7805 voltage regulator and you board would probably be the diecimila board. That chip is supposed to get somewhat warm but if it got really warm then it means that there was a large current draw on the board. This could be due to a short circuit somewhere or maybe something you had plugged into the board.

A number of bad things might have occurred. If the atmel 168 chip got too low a voltage then it's flash could have gotten corrupted. If the bootloader is corrupted then you won't be able to use the USB interface to upload sketches. You can use a parallel port programmer to do it. Chances are, you don't have one of those. You also could have some other component which is bad.

Depending on how seriously you are into this (as a hobby, a job, a very serious hobby, etc) you really should invest in spare parts. Get some 7805's, some spare caps, resistors. You really also ought to order up more atmel 168 processors. It's best for the hobbyist to order chips already programmed with the bootloader so that you don't have to get special stuff to do it yourself. Though, a programmer can be used to reload the bootloader onto chips you've gotten corrupted so if you are dealing with a number of arduinos then it might be worth it.

In short, I think that you are going to have to assume that your board is damaged in some way.

Okay, I'm getting basically the same error, and I've come to the same conclusion, i.e. something is damaged. The thing is nothing visually looks bad, the ps led comes on, and the pin 13 led flicks on reset, flicks multiple times when I try to upload (which fails with the out of sync error), and even flicks when I pulse the dtr line on the serial connection.

If the parallel port programmer doesn't fix it, then what else could be wrong? Some weird damage with the atmega? In my experience ICs usually completely go when they do, never partially. If so can I just buy blank atmegas, pop 'em in the arduino and use my parallel programmer to flash the bootloader?

I've got a similar problem that I can't upload sketches to my Arduino. I have a feeling that the USB chip might be fried but I don't know for sure. Is there any way of troubleshooting that chip?

The sad truth in hardware design is no.

The hardware way of troubleshooting is:

  1. Check that all DC power supplies are within limits.

  2. Guess what is not working, you base your guesses on different measurements on the board, if the chip is discolored it is a quite easy guess.

  3. Swap the chip and hope your design starts again.

  4. If it does not start, make a new guess and change another chip.

You also have problems with bad soldering joints, conductors broken inside the board etc

Magnus