Arduino digispark

A while ago I bought a arduino digispark. For a while now I have been trying to use it and have been unsuccessful with it. The issue is right when I hit upload and plug in the device it does not upload. If anyone has a solution to this please help.

This my help - and there are a lot of information in the net...

The issue is right when I hit upload and plug in the device it does not upload.

Is that really the order that you are doing things ?

By coincidence I just came across some Digispark boards from long ago.

Install Digispark in the boards manager if not already.

Choose Digispark 16.5 default board.
Choose the “micronucleus” bootloader.

And yes, hit upload and when told, turn on (or plug in) the previously not powered (or unplugged) Digispark. You never see or deal with the port. It seems like micronucleus looks around for it?

I have a little adapter that just cuts the USB 5 volt lineto the board, that is sufficient but plugging in the entire board works fine if less convenient.


BTW and FWIW, you might want to check/confirm how i/o line 5 is configured. On my units it is labeled Reset but is in fact a normal i/o. You can change this, it’s a little not for the faint of heart however.


So are you saying it works if you cut the 5v line.

So are you saying it works if you cut the 5v line.

That's exactly right, works here.

The adapter I have must have come with the Digisparks, it's just a little USB male to USB female thing with a switch to cut the 5 volt line.

Curiously when the power to the Digispark is cut, the little adapter board LED is ON.

Either have the power line open (or the board removed from the USB), wait until you see the message

Running Digispark Uploader...
Plug in device now... (will timeout in 60 seconds)

in the area where you compiler message and errors show up at the bottom of the IDE edit window and then power up (or plug it in).


thanks for the help

Sorry I have one more question what type of digispark were you using the one that plugs directly into a computer or the micro usb one. I am using micro usb and I am unsure about which wire to cut on the cord.

Well I've had my head down and did not know about the boards with a real USB connector.

Mine are the ones with USB contacts on the PCB, you just insert it into the USB port (I use the switch adapter on the end of an USB extension cable).

You could try

A. plug / unplug the USB cable with the Digispark on it - leave the Digispark on the cable, plug and unplug at the computer (or USB hub) end.


B. figure out which is (and how to interrupt) the 5 volt line in your cable or anywhere you can insert a switch. USB is standard, so which is 5+ should be easy to find.

I mention USB hub, try with and without or if you can be sure USB 3.0 vs USB not 3.0. For once things worked better with the hub than without, in this case the Adafruit Trinket, which I also came across recently in my to-do box, gonna try to deploy them before they become tots unusable.

If neither A nor B works, I have to wonder if your style of Digispark is even programmed the same way.

In any case I have to mention the "micronucleas" thing again - it's just that that was what kept me guessing for some time. Google my friend and I worked that out.

HTH and good luck! These tiny micros are way fun to park all over the place doing little things.