arduino does not respond

I have build my own serial singlesided arduino with the atmega8 it worked great for about a month but a few days ago, it stoped workig. I re-burned the bootloader and it seems to work properly the led at pin 13 blinks each 9-10 seconds but when trying to upload a sketch it does not respond. I have tried to use arduino 0007 alpha and 0010 alpha. in the first case I get the error message programmer is not responding and in 0010 I get: avrdude: stk500_getsync(): not in sync: resp=0xbe I have revised all the solderong and conections but they are all ok I thinck the problem is in the atmega8 how could I know if it is OK or if I have burnt it? what other reason could be causin this? thank you

Are you pressing reset button right before clicking uploading? Did you try pressing it 10, 15 or 20 seconds before clicking upload?

If this don't solve the problem, then the problem could be the serial cable, or serial circuitry on board. If the led on pin13 blinks every 9-10 seconds, sounds like atmega is fine.

Also, what operating system are you on? What are you using for the serial communication (a normal serial cable, a USB-to-serial converter, etc.)? Did you change it? (Some serial cables don't wire all the pins, some USB-to-serial convertors don't work very well.)

I have tried to press the button at different times before uploading, im usin a normal serial cable on win XP which has worked fine untill now. is there a way to test the cable(I dont have any other serial device. couldent it be that yust one pin of the arduino is wrong? thanks

(update: I have used a led to test continuity through the cable, pin 2 3 and 54 worked ok)