Arduino doesn't run sketch if not connected by USB cable

Hi There,

I am fairly new to arduino and have been running a basic sketch using Servos. When the cable is connected between the computer and the arduino, the program runs accordingly. However, when I unplug the cord and powerup the arduino, it continues to run the Blink.ino program. What can I do to fix this, so that when it boots up the last program I uploaded runs?

Thanks!

kiranarduino:
Hi There,

I am fairly new to arduino and have been running a basic sketch using Servos. When the cable is connected between the computer and the arduino, the program runs accordingly. However, when I unplug the cord and powerup the arduino, it continues to run the Blink.ino program. What can I do to fix this, so that when it boots up the last program I uploaded runs?

Thanks!

What you describe is simply not possible.
Once a sketch is uploaded, the old one is gone!

Well, that is what is currently happening? Once disconnected and powered up our arduino just runs the program that moves forward and blinks. Any other suggestions or possible problems?

kiranarduino:
Well, that is what is currently happening? Once disconnected and powered up our arduino just runs the program that moves forward and blinks. Any other suggestions or possible problems?

magic?

You're probably confused between the flashing that the blink code produces and the few short flashes that happen when the Arduino boots.

I suspect you have a power problem; how do you power the Arduino and the servos. A hand drawn or real diagram will be extremely useful.