Arduino doesnt upload sketches and keeps the blink sketch


A few days ago i was using my arduino uno, i uploaded the blink sketch and now i cant upload any other sketch, the program says upload successfully but it is always the blink sketch, i tried burning the bootloader from another arduino and now it have the same problem, and i did it correctly the conections between the two arduinos, the bootloader led is always on, what it could be? i need a third arduino to fix these two? im scared of broking a third arduino even following a video, thank you

Hello Koselillo,

Thank you for sharing your issue with the Arduino community.

I would suggest you try the following:

  1. Try to connect the board to a different computer and press reset on the board. Make sure you use a standard USB data cable (not charge only cable) and ensure it is inserted properly.

  2. Try to upload a different sketch or modify the delay of the blink sketch to see if you can upload.

  3. If this did not help, make sure you are selecting the right board type and port from Tools menu.

  4. When you tried to re-flash the bootloader using a second UNO, did you manage to upload successfully 'Arduino ISP' sketch to the programmer board?

Let me know how it goes!