Arduino Down with AVRdude errors

I experienced a problem where my Freeduino would no longer accept programs. Here is what I wrote for myself to document the problem in case it happens again:

Error Message Displayed When Freeduino Went Down:

avrdude: verification error, first mismatch at byte 0x0000
0x0c != 0x00
avrdude: verification error; content mismatch

In the end, I followed the instructions on this page:
http://arduino.cc/en/Tutorial/ArduinoISP.

I had to search for the ArduinoISP firmware as it was not found on the Examples page as I thought it would be. When I searched I found a topic in the Arduino Forum (search topic: "ArduinoISP

firmware", find :http://www.arduino.cc/cgi-bin/yabb2/YaBB.pl?num=1269695790) clicked on the link to the file on the link in the forum post and downloaded the ArduinoISP file.

I followed the instructions but when I went to burn the bootloader to my Freeduino, I received another error message of which I did not copy and cannot find.

I went to Arduino IDE and looked under the File>Examples>ArduinoISP option, clicked on it to open the file. I uploaded the sketch to my Duemilanove, connected the jumpers as shown in the first diagram of the page provided above. I followed the next instruction and clicked Tools>Burn Bootloader>w/ Arduino as ISP. It worked! Awesome, back to work! What a pain but I guess
happens. As a note, the Freeduino locked up (would not be programmed) after I tried to use the “Master Reader/Slave Sender” tutorial found here: http://arduino.cc/en/Tutorial/MasterReader.

When I looked at the ArduinoISP firmware that came with the Arduino 0021 version, the IDE’s version looks like it is older than the one on the page found above. Now that I go back and read, the ArduinoISP file that I downloaded looks like it is for a module using an ATmega8. Trial and error and read.

Notes about the situation:

  1. Both Arduino modules were connected to USB ports that are stacked one above the other.
  2. One board is not fully isolated from the varnished table. This means that there is one corner that touches the surface of the table, albeit dry. This is not the module that did not work.