Arduino DUE - nach Power cycle Reset notwendig...normal?

Hallo Leute,

kurze Frage:

Verwende einen DUE mit TFT shield und 7" TFT Touch... am eigentlichen Programm bin ich noch am schreiben.

Beim uploaden(also unmittelbar danach ohne Trennung vom USB) mit IDE 1.8.4 am Programming-port funktioniert das ganze auch direkt...(Sketch läuft)!

Aber sobald ich dann die USB-Verbindung trenne und auf externe Versorgungsspannung gehe, tja dann bleibt zunächst das TFT dunkel - ein kurzer Druck auf den Resetbutton am DUE und ZACK läuft alles wieder.

Egal ob ich auf extern mit 9V Netzteil oder wieder USB verbinde ...

Nach dem Aufspielen und Power off, bleibt das Display beim nächsten Einschalten erstmal aus, erst nach Reset am DUE läufts wieder.

Ist das normal?

Liegts am DUE oder am TFT oder TFT shield?

Oder gar am code selbst?

Das ganze (also HW) hab ich auch mit dem Mega gegengeprüft, da läuft alles wie gewohnt...wenn bereits upgeloaded, einfach Strom drauf und alles startet ganz gewohnt -ohne extra RESET zu drücken.

MfG Chris

Setzt mal in deiner setup ganz oben ein delay(5000) ein. Vermutlich braucht das Display etwas länger, bis es nach einem Spannungsfall ansprechbar ist. Wäre zumindest eine plausible Ursache

Hi,

habs gerade probiert... hat nicht geholfen :o(

Hab grade auf dem englischen Forum aber bereits gelesen dass es wohl manche R3 boards betrifft

Soll wohl 3 mögliche Abhilfen geben:

  • Kondensator 10µ an den Reset-Button(soll jedoch zu Lasten der Taster-Lebensdauer sein)
  • einen 10K Widerstand an FET T3 einlöten
  • 16U2 neu flashen mit modifizierter fw

Werd morgen mal auf die SDuche nach 0603 Widerständen gehen...

Hallo :

Hallo, ja genau...den fred hab ich gestern noch gelesen.

Hab heute nen 10k Widerstand reingemacht - FUNKTIONIERT einwandfrei!!!

MfG, Chris