arduino DUE R3 not syncing. drivers good. port good. what am i doing wrong?

i am running windows 7 64bit
i downloaded and installed the software 1.0.5 as well as the other items in the check boxes.
device manager shows Arduino Due Programing Port (com4)
i have com port 4 selected in software
i have duemilanove w/ATmega328 selected
tried 3 different micro usb cables

keep getting this error everytime i try to upload: avrdude: stk500_getsync(): not in sync: resp=0x00

any help greatly appreciated.

Has it ever worked before?

no. new unit received in the mail. also to note, after compiling has completed the RX led blinks 3 times on the unit. then i get the error message

Do you have any switches or LEDs connected to the Arduino headers?

tried with and without. at the time just 1 led from 13 to resisitor to ground. simple blink test
on for one second off for one second....

Your USB i/p ATMEGA16U2-MU may have to be re-programmed or it's bad.
I have a UNO so maybe someone can suggest the programming.

i am a bit new to this thing. how do i go about reprogramming?

If it's never worked I'd be tempted to send it back.

well don't i feel like a moron.
due to lack of prior research i did not realize you need 1.5.2 beta to program this board.... i watched a video on youtube of a dude unboxing and programming the Due and he used 1.5.2....

sorry for wasting time. thx everyone for your help.