Arduino Duemilanove Ubuntu 10.10 problem with ethernet shield

Hello all I'm having a problem with the Ethernet shield uploading the sketch's on ubuntu 10.10 Im using the version 0022 and to do a successful upload to the board I had to unplug the shield. this is very strange and inconvenient Does anyone have the same problem?

Which Ethernet shield are you using? Been using this one http://www.arduino.cc/en/Main/ArduinoEthernetShield for quite some time without any upload problems. Is there anything else connected to the arduino? Which arduino board are you using? Can you upload a simple sketch like blink with your Ethernet shield connected? What happened if you leave the ethernet shield connected but disconnect the ethernet cable?

hello
thanks for your answer.My shield is different from the link you provide.I attach a picture of mine and also my arduino board.
The one I have it was sold to me as a original part of arduino. The main differences is the components are in other places on the board.
(Ijust hope the layout is different).
About your suggested test I cant even send the link sketch with the shield connected without the lan cable.with it is the same result
I haven’t tried yet in a windows environment to see if the is some wrong with Ubuntu.
I have nothing connect on the shield, this is very strange since the shield comunicates with arduino via SPI

main.JPG

arduino_board.JPG

back_shield.JPG

I ran across this, take a look, is this your ethernet shield?

http://www.watterott.com/en/blog/Upload-problem-with-Ethernet-Shield

yes my shield is like that, so it is a bug on the board assembly I will remove the resistor and the capacitor like mentioned.

Tomorrow I will post the result.

I have removed the 2 components just now and it is already 100% uploading sketches.
thank you mrtaylor for your great tip

Your welcome