Arduino Due's programming port says device not found on COM

Hi everyone,

I bought this Due a few weeks ago, I need the native usb port to do some keyboard/game console controller input project. It was working fine until today, IDE wont upload any code through programming port any more, always says No device found on COM. I’m pretty sure it is detected since I can see it in device manager and tools-port I tried a few different computer, didn’t solve it. Then i tired to upload the code through the Native usb port and it worked. But my usb input control wont work anymore. Also another strange thing is that arduino is always making a high pitch noise when either usb port is plugged. Press down the RESET button will stop the noise but it comes back after I release the button. :disappointed_relieved: :disappointed_relieved:

Anyone has any suggestion? Please help! I hope I didn’t fried my Due :disappointed_relieved:

Also sorry for my bad english ><

I found this post:

Does anyone know what is the "R23" emech(the ID in #8) is talking about? Where is it?