Arduino e batteria 12v

Buona sera, vorrei un vostro parere su un Arduino Nano+sensorshield collegato ad una batteria da 12v /12ah che viene successivamente abbassata da un Auto Trasformatore DC12V a DC7.5V tramite una presa jack.
Non riesco a capire perchè l'Arduino si blocca (tipo 4 volte su 5) quando lo alimento.
Anche se parte, dopo un po' di ore finisce sempre per bloccarsi.
Non può essere un problema di sketch, perchè al pc non succede quasi mai.
Secondo voi cosa può essere ?

Margarina:
perchè al pc non succede quasi mai.

io lo escluderei se non ci fosse quel "quasi"

Un auto trasformatore???...

https://www.amazon.it/gp/product/B00OB1UX3S/ref=oh_aui_detailpage_o08_s00?ie=UTF8&psc=1

sento aria di fail.
Non va bene ?

maubarzi:
io lo escluderei se non ci fosse quel "quasi"

diciamo che se al pc va bene, è quando si "freeza" alimentandolo con la batteria che dà qualche problema anche al pc, ma una volta avviato, non fa una piega

Ah! Intendono "trasformatore per auto"! :smiley: è un convertitore DC-DC ti tipo buck (abbassa la tensione, contrariamente ai boost che la innalzano).

Ciao l'autotrasformatore in elettrotecnica è questo ,quello è solo un riduttore di tensione in c.c.

Se dite posso provare anche con uno Step-Down tipo questo:

tanto ce l'ho in casa.

Altre idee ?

Se i 7,5V non ti servono per qualche ragione particolare, però, avresti anche potuto alimentarlo a 5V dalla presa USB: internamente funziona a 5V.

L'Arduino va fuori di casa, la batteria da 12v è ricaricata da 1 pannello solare.

Ho letto che tramite la presa jack servono 7,5v, non posso usare l'usb,o sbaglio ?

Margarina:
Se dite posso provare anche con uno Step-Down tipo questo:
tinxi® LM2596 DC-DC Step-Down Regolatore scendere registrabile Modulo di alimentazione + LED Voltmetro : Amazon.it: Fai da te

Molto meglio. Puoi anche regolare l'uscita un po' più alta (8 o 9V). È possibile che quel riduttore a 7,5V preveda un assorbimento minimo, che l'Arduino non sia in grado di fornire...

Se l'Arduino è un originale, o un buon clone, si può alimentare contemporaneamente i 5V e l'USB.

Ciao,
P.

? ? ?..

La cosa più conveniente, senza sprecare energia in calore, è alimentarlo a 5V dalla presa USB (o saldando due fili sotto, facendo attenzione alla polarità).

Margarina:
Se dite posso provare anche con uno Step-Down tipo questo:
https://www.amazon.it/gp/product/B00Q88BZZC/ref=oh_aui_detailpage_o00_s00?ie=UTF8&psc=1

Per provare si può, ma nel circuito definitivo non userei un modulo che di soli display consuma forse più del carico che alimenta.

Poi, per curiosità, il pannello da quanti V e W(picco) è?

Claudio_FF:
Per provare si può, ma nel circuito definitivo non userei un modulo che di soli display consuma forse più del carico che alimenta.

Poi, per curiosità, il pannello da quanti V e W(picco) è?

http://www.peimar.com/datasheet/Peimar_IT_brochure.pdf il modello è OS30P

Pm = 30w
Vmp= 17,65v
Imp=1,7A
Voc= 21,17v
Isc=1,9A

ora provo con lo step-down e vediamo se funziona

Margarina:
Pm = 30w
Vmp= 17,65v

Ah, ok, finalmente un pannello abbondante e non il solito pannellino da un watt :wink: Ci dovresti tirare fuori almeno 50Wh (alias 180kJ) al giorno in inverno, e il triplo in estate.

Il problema è perchè si inchioda in questo modo.
Con lo step-down sembrava funzionare, ma dopo dopo 2 ore si è inchiodato alla stessa maniera.
Non capisco veramente quale possa essere il problema.

Non so se è una stupidaggine, ma potrebbe essere l'umidità a fare ste cose ?

Margarina:
Non capisco veramente quale possa essere il problema.

Figurati noi che non conosciamo lo schema, non sappiamo come è stato collegato, ne cosa ci è stato collegato, e non vediamo neppure che programma ci gira... ::slight_smile:

Claudio_FF:
Figurati noi che non conosciamo lo schema, non sappiamo come è stato collegato, ne cosa ci è stato collegato, e non vediamo neppure che programma ci gira... ::slight_smile:

rotfl

E' per forza di cose, qualcosa legato all'umidità o al freddo.
Ho portato dentro la scatola di derivazione con la batteria e il trasformatorino e sembra che tutto funzioni bene,il nano non freeza +.

Poichè gli schemi,collegamenti,programmi sono i medesimi in ambo le configurazioni(pc-->usb, batteria12v-->trasformatore12v/7,5v--->jack) mi sembra siano da escludere.

Provo a chiudere e a isolare il tutto decentemente e vediamo che succede

Mha, è possibile che l'arduino si inchiodi per il "freddo"(circa 2-3 gradi)?
Qual è il componente che può avere problemi per questa ragione ?

Non è possibile, se porto fuori il tutto, dopo 20-30 min si inchioda. Lo porto dentro, aspetto 20min e riparte.
Non può essere neanche la batteria da 12v perchè ne ho provate 2.

All'arduino ci sono collegati dei sensori, niente di + .....
Cos è secondo voi ?

Claudio_FF:
Figurati noi che non conosciamo lo schema, non sappiamo come è stato collegato, ne cosa ci è stato collegato, e non vediamo neppure che programma ci gira... ::slight_smile:

come ti è stato gia suggerito....
comunque l'elettronica teme di più l'umidità che il freddo (ancuni computer vengono raffreddati con azoto liquido...)