Arduino e relè

Salve ragazzi,
sto realizzando una installazione lumino/sonora interattiva tramite arduino e max msp. Tramite arduino alimento e piloto 50 relè jzc-32F in maniera diretta(ovvero senza passare per dei trasistor come da manuale) ed ogni relè a sua volta pilota l'accensione e lo spegnimento di una lampadina. i relè sono alimentati a 5V ed hanno un assorbimento di circa 70mA(l'uno). Ad arduino ho collegato un alimentatore esterno di 12V 2A, senza alimentazione esterna(oltre quella usb) arduino non riusciva ad attivare più di 4-5 relè contemporaneamente. Ho notato che arduino si riscalda molto...ho pensato di inserire una ventola(di quelle da PC) per raffreddare arduino. Che ne pensate?
Grazie a tutti anticipatamente

Roberto

Uhmmm se non ricordo male, la corrente di assorbimento di un pin su arduino è di 40mA o 50mA...
Se gli fai passare 70mA ovvero il 70% di quella ammissibile penso sia normale che si scaldi. Mi chiedo come ancora non si sia fuso...
Non ti conviene usare dei transistor?
Quelli scaldano parecchio ma costano meno e a quel punto puoi raggrupparli tutti insieme e metterci una ventola senza problemi.

Di sicuro mi conviene usare dei transistor...il problema è che non ho tempo per rifare tutto. io farò in modo che al massimo si attivino 25 relè contemporaneamente in modo di avere al massimo un assorbimento minore di 2A che in teroria sarebbe la somma dei 40 mA per 50 porte(uso arduino MEGA). Credi possa funzionare?
Grazie per la riposta.

Se ti puo' far sentire tranquillo io in un progetto avevo arduino che non potevi toccare il chip vicino all'alimentazione senza bruciarti e ancora funziona :slight_smile:

Beh si, sinceramente mi tranquillizza.
Per il momento l'unico componente che ho trovato particolarmente "caldo" è stato il transistor.
Ad ogni modo 70mA su un pin di arduino mi sembrano comunque tantini.
Secondo te?

Sembrano tanti anche a me ma devo ammettere che nella mia installazione in auto sto pilotando un rele da 12v senza alcun accorgimento particolare. Due assieme non funzionano e d'estate mi da problemi. Infatti sto ri-disegnando il tutto copiando quasi spudoratamente (ho fatto modifiche minori) questo:

Io avrei progettato tutti coi transistor. Non so se sia possibile magari inserirli ora, a monte dei moduli rele' in qualche modo... Non credo che valga neanche come conto quello della somma della corrente tra tutte le uscite perche' i 40mA sono per uscita, e non e' che usi una uscita sola allora puoi tirarne fuori 400mA.

Se proprio devi dissipare io preferirei un elemento metallico sui componenti alla ventola.

Grazie a tutti!
Proverò ad ogni modo a risolvere…Vi farò sapere che soluzione deciderò di adottare…Di base non dovrebbe darmi problemi perchè quando non uso l’alimentazione esterna al massimo non riesce ad attivare i relè…quandi credo che se non dovesse esserci energia a sufficienza al massimo i relè non scatteranno come dovrebbero(o almeno spero) lasciando le luci accese.
Grazie ancora a tutti e se avete altri consigli sono sempre ben accetti.