Arduino Editor won't start on Macbook

Hello,

after working for months without any problem, the Arduino Editor won't start anymore.
Splash is showing with message "Starting..." and then nothing.

Any help will be appreciated.

Thanks
Jan

quit application can only be done by a "Force Quit"

If you start the IDE from the command line you can get some output on the cause of the problem. If you do so please post the full output here using code tags (</> button on the toolbar).

There are many things that could cause this. Purely a guess, but the most common one recently is described here:
https://github.com/arduino/Arduino/issues/6689
which occurs with Arduino IDE 1.8.4. It can be solved by installing Arduino IDE 1.8.5.

Thanks Pert, but nothing helps.
If I start Arduino from the console, no errors or other messages appear on the screen.

in the mac-settings, tab “security and privacy” I find and error such like “Arduino” has been blocked, because the program is signed by an unknown programmer (text is in dutch)
click on “open” does not solve the problem :frowning:

screendump is attached

Did you try installing Arduino IDE 1.8.5 downloaded from http://www.arduino.cc/en/Main/Software?

pert:
Did you try installing Arduino IDE 1.8.5 downloaded from http://www.arduino.cc/en/Main/Software?

Yes,
and also other previous versions

I haven't heard of this problem before but I don't have experience with Mac. Hopefully someone who does will chime in.

If you downloaded the official IDE then you don't need to worry about it being unsafe to run so it's really just a matter of configuring your system not to block the IDE from starting. That seems like the sort of thing that you will find more well documented in online macOS resources rather than Arduino as it's not a problem specific to running the Arduino IDE.

If all else fails there is the potential workaround of using the Arduino Web Editor:
https://create.arduino.cc/editor