Arduino Engineering Kit Board (MKR1000) not functioning properly


Something with my Arduino Engineering Kit has not been working properly. I built the drawing robot properly, downloaded Matlab and all of it's files and libraries, and uploaded the first drawing robot code to the board, and it worked. Servos and motors would move according to the code. However, I then unplugged everything and shut the board off, and when I came back to it a few hours later, nothing was functioning. Basically, the motors and the servo are not responsive to any of the code's inputs, even though the code is running, the board has been initialized for Matlab, and the battery has full charging(I double checked all of these things to make sure . I troubleshooted for several hours, and found that it cannot be a battery issue, as I've charged it fully several times, it should not be an issue with the code, because it is the preset code for the first drawing robot lesson in the course, I don't believe there is anything wrong with the board, because nothing has changed with it from the time I left it when it was working to the time I started it again, and the LEDs light up as normal, and I do not believe there is anything wrong with the motors or servo, because they were also working like usual, and when the board is turned on the servo moves a little bit, indicating there is some voltage going to it as it turns on. I've also tried resetting the board and uninstalling and reinstalling Matlab, to no avail.

Do any of you have any advice or ideas for troubleshooting? This is a $300 dollar kit and I would hate for it to go to waste. This is the first project I've done with the kit, less than 1-2 hours of use.

Thank you.


What is the status of the red Led besides the power Led when trying to upload the sketch Motor_test(Chapter 3.1.1 Dc motors-Hardware test section)?

Provide us a copy of the error you're getting in the serial monitor/console after uploading the Motor_test sketch in Arduino IDE (chapter 3.1.1 DcMotor).