Arduino Engineering-Kit (lost dcmotor MATLAB connection)

Hi to everyone!
I have a problem in the chapter guide 2.2 with the MATLAB command:


MATLAB answer is:
The host and client connection is lost. Make sure the board is plugged in and recreate arduino and related objects.

I have checked several times that everything is well connected, and it is, but I can not solve this problem and I always get the same MATLAB 'loss of connection' answer .
I want to clarify that I did this part of the project once and it worked properly, I could activate the dcmotor, to change the dutycyle and stop it. The problem occurred when the Li-Po battery was discharged, I recharged the battery and tried to run the previous project but I always obtain the same MATLAB message. Could you give me some suggestions?
Thanks in andvance

Hello Roberta,

Can you please follow the instructions in the chapter 3.1.1 Dc motors -Hardware section and upload the Motor_test. Later, open the serial monitor and provide us a copy of the output.

Thank you,

Thanks for the reply.
I tried to do what it suggests but the serial monitor does not give results.
I also tried other examples with serial monitor (examples that do not use dcmotor) and I got results on the monitor.
I used a multimeter to verify the output voltage of the li.po battery and it works correctly but if I try to measure the voltage at the ends of the dc_motor (M+ M-), when the circuit is connected, it results 0V.
Moreover the shield become very hot , is it normal?

doc1.pdf (504 KB)

Hello Roberta,

It is not normal if the controller (the square chip that is situated in the middle of the board) and the regulator are hot.The drivers can be hot after a period of use.

However, if the controller is hot,there is a possibility of short circuit and i kindly request you to make a hardware test on the MkrMotorCarrier by placing the multimeter probes between Vcc and GND in beep mode.

Please disconnect everything from the board while making this test.

Thank you!

Multimeter beep mode does not find a short circuit between Vcc and GND but finds it between M3+ and M3- (and between M4+ and M4-) pins of MKR motor carrier. It did not detect in M1+M1- and M2+M2- but the voltage on their ends is however 0V.
How is it possible if the only change between the work-status and no work-status was the charge of Li-po battery?

I thought to have a problem with the quality of the charge of Li-po battery.

doc2.pdf (514 KB)

Hello Roberta,

The short circuit between M3+ and M3- is because in the initial stages the board connects the two pins to ground, which is normal.

Can you please email us at and we will follow up on your issue.

Have a nice day!

Best Regards,

Thanks for the reply and clarification. I just sent an e-mail.

Have a nice day you too!

Hi Roberta,

I am in the exact situation as you were. Can you please tell me if you found the root cause and any fix ?

Appreciate any pointers.


Hello Aswani,

Please provide us a copy of the output after uploading the Motor_test and a picture of the circuit build where we can see the wiring on the board.