Arduino Engineering Kit rev2: Can't setup Arduino board in MATLAB

Hi,

I am currently following instructions to setup the Arduino Engineering Kit Rev 2 from here: Engineering Kit! (arduino.cc)

I am currently stuck on 1.3 Installing the Tools.

I am using MATLAB 2021a, and I installed the program from the direct link after registering my kit.

I followed the instructions to Install Matlab, and then installed the MATLAB Support Package for Arduino Hardware, but I am not able to Program or Test the connection for the Arduino board no matter what I try.

After checking the ‘Enable installation of Arduino USB driver’ and clicking yes to three times to allow the drivers to Install, I choose ‘USB’ then click ‘next’.

On the ‘Upload Arduino Server’ section, I choose board: “Nano33IoT” Choose port: “COM3”, and check options I2C, SPI, Servo, and MotorCarrier

When port is COM3 when I click “Program” I get an error message saying, “Failed to program the Arduino board. Click the following link to see the error log. Contact Technical Support if you need more help.”

When I open up Device Manager and pay attention to the ports, I notice that after Matlab fails to program the Arduino Board, the port changes from “COM3” to “COM7,” if click ‘Back’ then go back to the “Upload Arduino Server” page, the “Choose port” option changes to show COM7, and if I click “Program” it successfully programs the board and I am able to go to the “Test Arduino Connection” page.

But now, on the “Test Arduino Connection” page, once I click “Test connection” after a few seconds I note that on Device Manager the port will change from COM7 to COM3, then I get “Test connection failed” message, and if try to reprogram the board when it is on COM3, it fails with the error message.

So to summarize, when Device manager is on COM3 (default), it always fails to program. After it fails to program, the port for some reason changes to COM7, and COM7 will program the board and will allow me to go to test the connection, but then it will fail to test the connection because it will revert back to COM3.

I have tried uninstalling the Arduino USB drivers and rebooting, and have tried uninstalling and re-installing the MATLAB Support Package for Arduino Hardware add-on, I have also tried using different USB ports on my computer and have also tried using a different micro-USB to USB cable, none of those things work.

Please let me know how I can get this working. I attached the error log below

MWArduinoLog-210329162658.txt (1.79 MB)

Hello,

I wanted to provide an update in case anyone else ran into this issue.

I was not able to resolve the issue on my desktop computer, but I was able to install everything successfully on my notebook computer. I think this issue is because my desktop has an AMD Ryzen 5000 series CPU and there's currently a known USB stability issue: AMD Set To Roll Out AGESA firmware USB Fix For Ryzen, Coming April (anandtech.com)

AMD is going to release an update sometime in early April for the USB issue facing Ryzen 5000 series CPUs with 500 series motherboards, but until then I will just use my notebook computer to run MATLAB and the Arduino board

Thank you