Arduino environment doesn't open...

i have been using arduino for a while with Intel. no problems.
last week we tried to instal everything on my computer friend.
he was using MacOSX 10.3.7. we instaled arduino-0010, and it worked. but we couldn't manage to conect the software to ArduinoBT hardware. then we read that Arduino works with >= 10.3.9. So he updated MacOSX from 10.3.7 to 10.3.9... And since then ArduinoEnvironment doesn't open. we have tried Arduino0009, and the same. when we click on "Arduino" icon nothing happens...
what should i do?
thank you very much

If you open the Console application, do you see anything in the logs when you try to run Arduino?

thanks for the answer.
arduino environment works now after that i updated java and security updates!

but still another problem:
I am using ArduinoBT. the computer doesn't have integrated bluetooth, so we use a bluetooth usb external device.
when i open arduino_10 and i want to select Board and Serial Port i have this options:

for Board:

  • Arduino BT
  • Arduino NG or older w/ ATmega8
  • Arduino NG or older w/ ATmega168
  • Arduino Mini
  • Arduino Diecimila
  • LilyPad Arduino

for Serial Port:

  • /dev/tty.modem
  • /dev/cu.modem
  • /dev/tty.Bluetooth-Modem
  • /dev/cu.Bluetooth-Modem
  • /dev/tty.Bluetooth-PDQ-sync
  • /dev/cu.Bluetooth-PDQ-sync

what is the option i should select...?
thank you very much