Arduino ESP32 Import Error No module named serial

I googled and couldn't find a solution to my nice problem: I have Ubuntu and I want to program a ESP32 ............... I tried a lot of pip commands ... but it didnt work. You have any idea how to install the correct packages? Maybe you can tell me what to do. I am really lost. I tried it last year and also failed.. Now I want to try it another time :slight_smile:

   /.arduino15/packages/esp32/tools/esptool_py/3.0.0/esptool.py", line 38, in <module>
        import serial
    ImportError: No module named serial

Why did you post this in the covid-19-projects section of the forum ?

Your post was MOVED to its current location as it is more suitable.

Try this:

pip3 install pyserial

open the terminal and enter the command

python -m pip install pyserial

it will download pyserial for you and you will not receive the above error. The above error is because you don't have pyserial installed on the system.
source
The related documentation for pyserial could be found here