Arduino ethernet, cannot upload sketch

I am new to this. I bought an Arduino ethernet. As the supplier did not have the USB/Serial Light Adapter I bought the Mini USB/Serial Adapter, connected TX to TX, RX to RX and +5 and GND to etc. Green power light on the Ethernet Arduino burns. If I try to upload the blink sketch (Led variable changed to 9) I get the infamous AVRDUDE message. I did a loopback test by connecting the USB Adapter TX to RX and typed on the serial monitor, perfect response.

Is there anything else I can test ? I am not sure if the processor is running at all. If I measure voltage on the +5 pin I get only 4.4 Volts. Could that be too low ? Can I conclude that there is something wrong with the board ?

mastrigt: I get only 4.4 Volts. Could that be too low ?

Very likely

Can I conclude that there is something wrong with the board ?

Probably not.

I have no idea what you are doing with the Tx Rx stuff, maybe because my Ethernet is built-in, but I have had problems with power lately.

You make no mention of the power supply but I suspect it is via the USB cable, and it could be all down to that. I started with a USB cable, whic was actually OK, but I then tried a converted phone charger, good for 5.3v @ 1amp. It looked good and then the lcd went out. This happened when I started to use the Ethernet. In a separate exercise, I was checking the temperature under the board and it went up by a few degrees when, you'll never guess, yes, when I used the Ethernet.

In short, in the first instance, I was always a bit close to the edge and the Ethernet took that much more power to push me over the edge. The problem was fixed with a proper 9v supply. You may get by using a different USB port. The second instance just demonstrates that the Ethernet makes the regulators work that much harder i.e. a significant increase in power.

Further to this, I have recently changed the motherboard in the desktop. Even without the Ethernet shield, the Mega could not even run the RTC properly. To add insult to injury, the desktop refused to start with the Arduino connected. I transferred the cable to a separate port and the PC will now start OK, but I have not used the Ethernet with that.

thank you for your answer. My response is very late because I could not access this forum for a long time. Anyway : I now powered the Arduino ethernetboard via a separate lab power supply, and measured 4.99 V on the board. It still does not upload sketches, but gives the AVRDUDE error message. I did a loopback test. I am using the mini USB/serial adaptor, and connected Rx of the adaptor to its Tx . Works fine.

Subsequently I am a little bit uncertain about the connections between adaptor and ethernet board. I connected Rx of the adapter to Rx (digital pin 0 on the ethernet board) and Tx of the adapter to digital pin 1. I also connected GND of adaptor to GND of ethernet board. Is that correct ? Or should Tx of adaptor be connected to Rx of ethernet board, and Rx to Tx ? I tried both but both give AVRDUDE. I tried pressing reset during uploading many times, and once got a slightly different error message. I don't see a systematic LED response to pressing reset. I now think I don't have a functioning boot loader on the ethernet board. As I read many many messages about this problem, is there a whole series of boards with not functioning boot loader ? I have no hardware for updating my bootloader I think, not even another arduino. What can I do ?

Sounds like your USB to serial board doesn't have a RTS signal to connect to the Arduinos reset. You are going to have to manually reset the Arduino right before avrdude tries uploading. It'll take you a couple of tries.