Arduino Ethernet can't be reprogrammed: USB2Serial 'programmer not responding'

I installed Arduino IDE in Ubuntu 12.04 via Ubuntu software center. I uploaded the slow flashing led as a test to my Arduino Ethernet through the Arduino USB2serial light loader. Which always works if I power it up.

Now I try to load a new code (probing a bunch of digital Dallas temp sensors). Code compiles well, but I get back: “avrdude: stk500_recv(): programmer is not responding”. During this, only RX on programmer blinks a bit, TX not, Ethernet blinks not at all.

I checked the boot loader firmware ( avrdude -c arduino -p m328p -P /dev/ttyACM0 -v )
Then both RX and TX flash seriously, and I get back that firmware is 4.4, which means timing problems are supposed to be fixed, an dauto-reset enabled.

IDE settings: Tools Boards set to Arduino Ethernet (with USB2 …)
Tools Serial port set to …ttyACM0,
Tools Programmer set to Arduino as ISP.

Tried all advice I could find: holding reset while powering up Arduino.

The only Arduino- advice that I did not try is to login Ubuntu as Root, but then (in Ubunto 12.04) you loose the graphic interface. And without graphics, IDE can’t be handled. AND, my first upload worked with normal admin rights, so why not anymore?

One older forum suggestion was that first upload set the board to a different baud rate. Is that still an issue in recent firmware? If so, how do I fix that?

What else do I do?

Thanks, Pieter.

I love ubuntu. Can u give explanation ?