Arduino Fio + RN-42 Setup Probleme

Hallo,

ich habe mir einen Arduino Fio und ein RN-42 BT Modul (die x Bee Ausführung). Mein Problem ist jetzt das ich für das Setup diesen Code im internet gefunden habe, der aber nicht funktioniert :(

Arduino: 1.6.3 (Windows 7), Platine: "Arduino Fio"

sketch_apr07a.ino: In function 'void setup()':

sketch_apr07a.ino:4:4: error: 'Serial1' was not declared in this scope

sketch_apr07a.ino: In function 'void loop()':

sketch_apr07a.ino:7:8: error: 'Serial1' was not declared in this scope

sketch_apr07a.ino:12:7: error: 'Serial1' was not declared in this scope

Fehler beim Kompilieren.
void setup() {
   // Open serial communications and wait for port to open:
   Serial.begin(9600);
   Serial1.begin(115200);
}
void loop() {
   if (Serial1.available())
      Serial.write(Serial1.read());
   if (Serial.available()) {
      byte in = Serial.read();
      Serial.write(in); // local echo
      Serial1.write(in);
   }
}

Vielleicht hat von euch jemand mit dem Fio Erfahrung :)

MfG Janik

Den Fio sieht man hier selten, allerdings basiert der ja auf dem Atmega328p, wie auch der "normale" Uno. Das bedeutet, dass nur eine serielle Schnittstelle in hardware zur Verfügung steht, ganz genau das besagt auch deine Fehlermeldung.

Oh Danke :) Nach solchen "banalen" Fehlern habe ich nicht geschaut :D

Kann mir trotzdem jemand erklären wie ich das BT Modul in den Setup Modus bekomme? wenn ich " $$$ " eingebe bekomme ich z.B. " $$ 1 " oder ähnliches zurück. Aber ich komme nicht in den CMD Modus.