Arduino Fio + W5100 shield - example sketch doesn't work.

Hi,

Has anyone managed to get the Arduino Fio working with the W5100 ethernet shield? Here is how I am connecting the two boards:

  1. SPI lines: D10, D11, D12, D13 of Arduino Fio to D10, D11, D12, D13 of the W5100 shield.
  2. power: 3.3V - connected +3.3V and GND from Arduino Fio board to +3.3V and GND on the W5100 shield.
  3. Connected a lan cable from laptop to the W5100 shield.

The Link LED lights up, as does the PWR, 100M and FULLD led(s). However, the webclient example sketch in the ethernet library does not print anything in the serial terminal - meaning, it's probably hung in the "if (Ethernet.begin(mac) == 0) {.." part at the start of the example sketch.

Any tips on how I could debug the problem.

Thanks.

I don't know about the rest, but this is wrong.

  1. SPI lines: D10, D11, D12, D13 of Arduino Fio to D10, D11, D12, D13 of the W5100 shield.

You must use the ICSP pins on the ethernet shield. Nothing is connected to D11 to D13 on the ethernet shield. The SPI data lines are only connected to the ICSP pins.

Hi @SurferTim,

Thanks for your response - yes, I had naively assumed that pins with the same names would be connected across the two boards. I now have the Arduino Fio and the Ethernet shields connected via their ICSP connectors. I have also connected D2 and D10 on the Fio to D2 and D10 on the Ethernet shield. With these connections, I tried your test sketch at: http://forum.arduino.cc/index.php?topic=244542.0 - many thanks for the same! I am getting a 192.168.2.2 response -which indicates that the pin connections are now OK -correct?

However, I then tried the example, "webClient" sketch in the Ethernet library but do not get any response / print statement on the serial terminal. I have connected the Lan cable between the Ethernet shield and my laptop which is connected to the internet.

Does the lack of response to the webClient sketch, indicate a problem with a firewall or some other networking issue on my laptop? Can I, based on the test sketch in your forum and its response in my setup, assume that the pin connections and board setup itself is OK?

Thanks.

You must enable Internet Connection Sharing on the laptop.

Is someone still watching this thread?? I was working through some ethernet client sketches a few months back, and had good results. I just downloaded a new version of the arduino compiler (1.6.4 possibly), but cannot get these ethernet sketches to compile. I'm using a Radio Shack (seeedstudio) ethernet board with an Uno. Was I supposed to change some file contents somewhere along with importing EthernetV2_0 into the library?? I can't remember if I've made all of the necessary changes here. It still won't compile. I may get back here in about 12 hours or so, or it could be a week before I'm back here.???

I’m watching. You must download and import the Seeed Studios EthernetV2_0 library from Github.

Then you must change the include file in your sketch.

// change this
#include <Ethernet.h>
// to this
#include <EthernetV2_0.h>

I re-retrieved the 2_0 library (but maybe not from git hub), then tried to compile a sketch, and the compilation hung up on the IPAddress "line" in the code. Something is throwing me off here. I don't know if anyone can remember what's being done wrong here. It seems like it should take longer than 4 months to forget what I was doing with those sketches. What the heck???

You must use the library from Github. The library on the Seeed Studio site has a bug that involves the IPAdress data type in the IP assignment code.

Tim: I got the program working on the most recent release of the compiler. Thank you. I have to try to save thsee files as they are coming in now, to the SD card. It must have been that corrupted other library like you said. This git hub library is fully operational, like you said. This was helpful, thanks.