Arduino FIO x Xbee x As3

Hi !

i’m really a beginneer, and english is not my born language, so please be kind :slight_smile:

i’m working on a project (not really relevant to explain what, but i will if you are curious), and i’m triying to interface an arduino FIO board with an xbee and some action script 3 (as3)

i’ve setup my xbees like i was told here : http://funnel.cc/Hardware/FIO
i did everythings like they said (at least, i think i did…)

no i’m trying to play with the examples given in the funnel sdk, the basic one : ArduinoTest.fla
i’ve manage to export the swf… but :

  • when i plug the led on the 13 pin, it blink… even if i don’t start the funnel server, or flash…
  • on the .as file, i change everything from 13 (pin) to 12 (pin), to try make the led blinking on a different port. it doesn"t work. on the swf i see the 12 pin blinking, but in the real life, nada, zip, nothing… it stay off

more informations :

  • i took a picture (sorry for the quality) of what it did : http://www.creaktif.com/arduino.jpg
  • sometime, a green led turn on when i try to connect with flash or the arduino software. the RSSI led…
  • i tried upload a standart firmadata from the arduino software… it tries, the green RSSI led is switching on, and after a few second the arduino app tells me “programmer not responding”

anyone can help me ? i feel really lonely and dumb right now…

Thanx

Ho, and i run on mac os X 10.7 "lion"...

i managed to solve the problem :

  • the upload to the board worked at some point...
  • i change the firmware do standartFirmata 2.2
  • i change the board type in the funnel server

i have this error every time i start the server :


WARNING
You must upload StandardFirmata version 2.3 or greater
from Arduino version 1.0 or higher


but so far it works so...