Arduino for OS-X Java version to old

Please upgrade Arduino.app to the most recent Java version.

The present version of Arduino.app cannot run on a Mac with OS-X 10.10.1 since it needs an older Java version.

Captura de pantalla 2014-12-25 a las 10.21.19.png

I have the same problem, and I solve whit Arduino 1.5.8 BETA release.