Arduino "forse" bruciato

Ciao a tutti, ho un problema con il mio arduino diecimila. Tentando di collegare un lcd ad arduino ho commesso il grave errore di collegare il pin che regola il contrasto direttamente al gnd senza una resistenza, appena l'ho collegato ho notato che la luce del led power si è affievolita, quasi spenta. Subito ho staccato l'alimentazione usb(era collegata solo quella) e ho staccato tutti i pin. Dato che non si sentiva puzza di bruciato ho ricollegato la scheda all'usb, ho provato a caricare un codice per un contagiri(sembrando tutto funzionale) e ho notato che, nonostante non avesse il sensore attaccato, il led L lampeggiava a caso e inviava al monitor seriale un numero di giri casuale, cosa che non succedeva prima(la luce rimaneva spenta o accesa e il risultato rpm senza sensore era sempre 0). Però attaccando la fotocellula torna come prima ad inviare come risultato 0 e testando normalmente la cella sembra contare i giri senza errori.
Sapete dirmi come posso capire cosa ho bruciato o danneggiato? magari, se esiste, un programma che testa le funzionalità e l'hardware dell'arduino, in modo da vedere se devo cominciare ad ordinarne uno nuovo.

Se ci dai una foto in HD forse capiamo meglio il problema :slight_smile:
in teoria l'atmega dalla tua descrizione non dovrebbe essersi fatto nulla.

Foto della scheda? sulla scheda non vedo nulla di diverso, in ogni caso ecco:



Ho fatto anche un video del mio problema, appena finisco di uplodarlo(20mb) lo posto.

Ecco il video:

Ciao,
secondo me non hai bruciato niente. Non so come funzioni il contagiri che hai usato ma presumo sia normale tu abbia dei valori casuali letti dalla seriale in quanto gli ingressi di Arduino sono lasciati "floattanti". Senza resistenza di PULL-UP/DOWN o senza un riferimento a massa il micro può andare in confusione.

Quoto DevonMiles.
Se si fosse bruciato qualcosa, non avrebbe funzionato l’Arduino. Qui invece funziona: l’unica anomalia, se così si può chiamare, è una lettura “strana” dei sensori ma è normale con i pin “volanti”. I pin dovrebbero “sentire” anche la vicinanza della mano o di masse metalliche.

io uso abitualmente il pin di contrasto collegato direttamente a gnd...
non dovrebbe essersi bruciato nulla...le letture strane saranno perchè hai lasciato i pin appesi che quindi leggono valori flottanti e captano le radiazioni em
non ti coniene comunque caricare uno dei programmi di esempio?