Arduino Gemma not entering bootloader mode

I recently got an Arduino Gemma and was not having any problems connecting to my computer and uploading code for a project. I haven't figured out SoftwareSerial quite yet, but my code basically makes the red LED blink rapidly when there is no input. So when the Gemma was working, I could press the reset button, the red LED would pulse to indicate that it was entering bootloader mode, and continue to execute the program by blinking rapidly.

However, after a couple of connections to my computer, the red LED stopped pulsing when I hit the reset button, just turning off for a couple of seconds before executing my program again. I tried plugging and unplugging the Gemma into USB 3.0 then USB 2.0 ports. It also did this when the Gemma was only connected to a battery, so it's almost like the Gemma thinks my computer is just another battery, and is not recognizing that it is connected to a computer.

I then tried to repair the bootloader, using Adafruits tutorial, and now my program has been erased/does not execute; the LED just turns on very weakly for a couple of seconds, then turns off.

Does anyone have an idea of how to completely reset the Gemma or what could be wrong?

I had the same symptoms with 2x Trinkets, the Gemma's "cousin". Wouldn't go into bootloader on two different laptops, although both had worked a month or so before.

Then it struck me: the common denominator to the non-working setup was the cable. Tried another and all was good in TrinketLand again.

(Seems one of my cables is a charger-only cable I guess, with no data lines?)

So, have you tried another cable?

So, have you tried another cable?

I have and unfortunately it didn't help either.