Arduino gets stuck, but not during voltage monitoring

Hello everybody,

I'm working on my first Arduino project and this is also my first post here, which does not mean I'm new to this place :slight_smile: I already made researches here and at other places, but still have no solution to my problem.

I'm building a self balancing robot (yeah I know what a surprice for the first project) with following components:

  • 2x 6 V DC motor
  • L298N motor driver
  • MPU6050 gyro + accelerometer
  • Boost converter (5 V -> 7.8 V)
  • 10000 mAh USB power bank with I_max = 2 A

I use the boost converter to increase the voltage from 5 V to 7.8 V, so that after the motor driver uses 1.8 V the remaining 6 V can power the two DC motors. Arduino is powered by the 5 V regulator of the motor driver. All components share a common ground.

During quick speed or direction changes of the motors, the Arduino gets stuck and remains at a constant PWM signal where also the serial monitor freezes. Seems like during such operation the drawn current drops the voltage and the Arduino is not powered sufficiently.

I replaced the power bank by a bench power supply and the problem was solved.

Just to doublecheck I wanted to figure out how much the voltage drops during quick speed or direction changes of the motor and connected the power bank again and also a multimeter. The negative probe was connected to V- at the input of the boost converter and the positive probe at V+ at the output of the boost converter. While the multimeter is connected as described the Arduino didn't get stuck. How is that possible? Is it possible to solder a high resistor where the multimeter is currently attached and solve to problem?

Thanks in advance :slight_smile:

Congratulations, you have already solved the problem. Remove the boostconverter and use 2s lipo and you will be fine (at least if you use a decent size, i.e. > 1000mAh)

Thanks for your answer. But I'm still curious why the problem disappeared by measuring the mentioned voltage?

BTW: The current drawn while connected to the bench power supply was at max 0.8 A. Does the current change too quickly, so that the voltage drops? But even though the voltage dropped from 7.8 V to maybe 7.5 V, which is still plenty enough.