Arduino IDE 1.5.3 (intel Galileo) for Mac OS X doesn't work

Hi everybody! I hope this is the right section of the forum. I'm a Mac user and from two days also a Galileo user :D. I have an issue with the mac version of the arduino IDE (1.5.3): simply it doesn't work! First thing I tried was the firmware upgrade, but after selecting the serial port, clicking on "firmware upgrade" and clicking YES on first popup message, the applications crashes and no other popup or messages appear (I tried on two macs). So I tried with a Windows pc and the firmware upgrade was fine. Finally I wanted to upload a sketch on the board with the mac and the IDE crashes again. As I said, i have these issues on two macs: a macbook pro 13" (mid 2010) running mac os 10.8.5 and an imac 21,5" (2011) running mac os 10.8.5. On the macbook i have also installed arduino 1.0.1 but not on the imac. Any idea? What can I do? Thanks.

I have mine up and running (Mac 10.7.5). One thing I've done is make sure the USB cable is connected directly to your computer USB port rather than a hub.