Arduino IDE 1.5 kust stopped compiling on any home made code

I am perplexed.I have An Arduino no r3 running 1.5 and since I installed it about a month ago, everything would compile and upload great. All of a sudden, the IDE just stopped compiling all m home mad code and will only compile the examples which were installed with the IDE.The ID will almost finish fine, with the green bar almost done, then it stops and says error;compile. I wrote a lot of code for the Sainsmart 2004 LCD with I2C backpack and it was always very successful and theu would upload wonderfully. Now, nothing will even verify, but the Blink example will verify/compile and then I can up load it and it works as noted. I had the luxury to re-format, re-install windows 7, 64 bit and still no go. I tried VISTA 32 bit,, and it will not work, same problem. I love this product, but I am really thrown off course by the problem.Could I be missing some installation ?

PLEASE HELP.. Any help is resolution would make me a newly learned man.

rbots:
…would compile and upload great. All of a sudden, the IDE just stopped compiling…

I have had my years in working in “support”. The conversation usually runs like:

  • It stopped working!
  • What did you do?
    -Nothing!
    -Why are you sitting in fornt of your computer if it isnt doing “something”?
  • ?! Oh well, yes, I just did

Over to you: When was the last time you Know it Worked. When was the First time it Stopped? What did you do in between…