Arduino-ide-1.6.0 + due on the Raspberry Pi

Sorry Folks, this only works for jessie because of Arduino-ide requirements.

I got myself a Arduino due a few months ago and since it is gonna be hooked up to
a Raspberry Pi, I wanted to be able to program it from the pi.
I have managed to compile hello world and upload just it fine.
Although this was done on the Pi, it might work on any Debian Arm system.

So here is what I’ve come up with…
I live on the wild side and always play as root, so…

During the upgrade to jessie you are asked some questions

Restart services during package upgrades without asking?
I answer yes to it.

Do you want to keep the old config’s or install the new 1’s.
In all but lightdm.conf, accepting the ‘default=N’ seems to work fine.
So say ‘Y’ to lightdm.conf, so it does not bork the system,
the only thing you will loose is the auto-login of user pi to the desktop which we will put back in.

sed -i 's/wheezy/jessie/' /etc/apt/sources.list
apt-get update
apt-get upgrade -y
apt-get dist-upgrade -y
sed -i 's/#autologin-user=/autologin-user=pi/' /etc/lightdm/lightdm.conf

I always play in /usr/local/src, but play where ever you like…

cd /usr/local/src
unzip -q
cd Arduino-ide-1.5.x
tar -xf arduino_1.5.6.2+sdfsg2-3.debian.tar.xz

Now we need to fix up the debian directory with a patch

cd debian
patch -p1 <
cd ..

Now we can make the deb’s

dpkg-buildpackage -uc -b

apt-get install any missing build dependencies and rerun

And finally we can finally install Arduino-ide-1.6.0

cd ..
dpkg -i arduino-core_1.6.0_all.deb arduino_1.6.0_all.deb

Have Fun and A Great Day
ShorTie … :wink:

I have a raspberry pi 2 running wheezy-based raspian linux. My Arduino IDE is v1.0.1 but I want to get up to 1.0.5 if I can in order to use a library that will not work on my UNO without the higher rev IDE. Is there a path to get there in wheezy? If not, is there a detailed howto on going from stable wheezy to jessie?


THANKS to ShorTie now works with IDE 1.6.4
i try today on a RPI model B

I tried this and all went well up to the point of running the patch. When I run the patch I get the following error:

sudo patch -p1 <

patch unexpectedly ends in middle of line
patch: **** Only garbage was found in the patch input.

I tried looking at the patch file with nano but I have no idea what I am looking at. My objective is to install Arduino 1.6 on a Raspberry Pi 2 so I can use it to program an Arduino Due.

This info is old, from December 2014.

Since then, Arduino started fully supporting Raspberry Pi. Just go to the download page and get the LINUXARM download. Extract it and run, just like you would with any Linux PC.

Arduino 1.6.9 works great on Raspberry Pi. No patching needed.

Thanks, I had tried that several months ago but did not retry when looking into it again today. I will give it a try!

Arduino 1.6.9, the first official release with LINUXARM support, was published just under 2 months ago, on May 10th 2016.