arduino IDE 1.6.10 java errrors

Hi guys
I downloaded IDE 1.6.10 and forever get this error

Arduino: 1.6.10 (Windows 7), Board: "Arduino/Genuino Uno"

"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs  "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\core.a" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\abi.cpp.o"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs  "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\core.a" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\main.cpp.o"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc-ar" rcs  "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\core.a" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\core\new.cpp.o"
Linking everything together...
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc" -Wall -Wextra -Os -flto -fuse-linker-plugin -Wl,--gc-sections -mmcu=atmega328p  -o "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.elf" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp\sketch\Blink.ino.cpp.o" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/core\core.a" "-LC:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp" -lm
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -j .eeprom --set-section-flags=.eeprom=alloc,load --no-change-warnings --change-section-lma .eeprom=0  "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.elf" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.eep"
"C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-objcopy" -O ihex -R .eeprom  "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.elf" "C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.hex"

Sketch uses 928 bytes (2%) of program storage space. Maximum is 32,256 bytes.
Global variables use 9 bytes (0%) of dynamic memory, leaving 2,039 bytes for local variables. Maximum is 2,048 bytes.
___REMOVE___/bin/avrdude -C___REMOVE___/etc/avrdude.conf -v -patmega328p -carduino -PCOM8 -b115200 -D -Uflash:w:C:\Users\John\AppData\Local\Temp\builde457850a21f0e19174341e1010577179.tmp/Blink.ino.hex:i 
java.io.IOException: Cannot run program "___REMOVE___/bin/avrdude": CreateProcess error=2, The system cannot find the file specified
 at java.lang.ProcessBuilder.start(ProcessBuilder.java:1048)
 at processing.app.helpers.ProcessUtils.exec(ProcessUtils.java:26)
 at cc.arduino.packages.Uploader.executeUploadCommand(Uploader.java:130)
 at cc.arduino.packages.uploaders.SerialUploader.uploadUsingPreferences(SerialUploader.java:209)
 at cc.arduino.UploaderUtils.upload(UploaderUtils.java:78)
 at processing.app.Sketch.upload(Sketch.java:1187)
 at processing.app.Sketch.exportApplet(Sketch.java:1160)
 at processing.app.Sketch.exportApplet(Sketch.java:1132)
 at processing.app.Editor$DefaultExportHandler.run(Editor.java:2409)
 at java.lang.Thread.run(Thread.java:745)
Caused by: java.io.IOException: CreateProcess error=2, The system cannot find the file specified
 at java.lang.ProcessImpl.create(Native Method)
 at java.lang.ProcessImpl.<init>(ProcessImpl.java:386)
 at java.lang.ProcessImpl.start(ProcessImpl.java:137)
 at java.lang.ProcessBuilder.start(ProcessBuilder.java:1029)
 ... 9 more
An error occurred while uploading the sketch sometimes very seldom and all is ok but most of the time no go. Any idea's to rectify

Look at all of the other 1.6.10 problem threads. THe whole section is full of them. DrAzzy knows how to fix it I think :slight_smile: -shoot him a PM. I think :slight_smile:

I was able to fix that issue by opening and closing Boards Manager but it didn't work for a couple other people.