Arduino IDE 1.6.3 wont start up

i have been at it for hours now. after i download the 1.6.3 ide and try to start it it wont work. please help have a lot of work to do?

You can get more information starting the IDE with arduino_debug.exe instead of arduino.exe. Open command prompt, change directory to the one you installed the IDE into and type arduino_debug

i have an arduino uno

Unfortunately that's not enough. Please follow this steps. Open command prompt, change directory to the one you installed the IDE into and type arduino_debug.exe. You'll get some error message you can paste here: that will help better understand your problem

Thank you lucho1381. One more step please. Copy the WHOLE output, not just the first line

C:\Program Files (x86)\Arduino> arduino_debug.exe
Loading configuration…
Initializing packages…
java.lang.NullPointerException
at processing.app.BaseNoGui.createToolPreferences(BaseNoGui.java:767)
at processing.app.BaseNoGui.initPackages(BaseNoGui.java:606)
at processing.app.Base.(Base.java:256)
at processing.app.Base.guardedMain(Base.java:198)
at processing.app.Base.main(Base.java:113)

Great thanks. It looks like there is an error in the tools you have installed. Please open windows explorer (or just explorer) and, in the address bar, type "%APPDATA%\Arduino15" (without the quotes)

You should find a folder named "packages". Delete it and restart the IDE

Not starting on my Macbook nor on my iMac running Yosemite 10.10.2
Splash screen appears until “preparing boards” then disappears
If I run it with the terminal I receive :

/Applications/Arduino\ 1.6.3.app/Contents/MacOS/Arduino ; exit;
macbookpro0322027190824772601960:~ **..**$ /Applications/Arduino\ 1.6.3.app/Contents/MacOS/Arduino ; exit;
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/attiny45_85/cores. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/attiny45_85
  No valid hardware definitions found in folder attiny45_85.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/calunium/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/calunium/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/calunium/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/calunium
  No valid hardware definitions found in folder calunium.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/chip45/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/chip45/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/chip45/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/chip45
  No valid hardware definitions found in folder chip45.
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/diy Arduino
  No valid hardware definitions found in folder diy Arduino.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Gnusbuino/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Gnusbuino/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Gnusbuino/pcb. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Gnusbuino/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/Gnusbuino
  No valid hardware definitions found in folder Gnusbuino.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/LeoStick/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/LeoStick/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/LeoStick/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/LeoStick
  No valid hardware definitions found in folder LeoStick.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/maniacbug-mighty-1284p-68ed99c/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/maniacbug-mighty-1284p-68ed99c/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/maniacbug-mighty-1284p-68ed99c/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/maniacbug-mighty-1284p-68ed99c
  No valid hardware definitions found in folder maniacbug-mighty-1284p-68ed99c.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/mighty/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/mighty/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/mighty/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/mighty
  No valid hardware definitions found in folder mighty.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Mosquino/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Mosquino/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/Mosquino/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/Mosquino
  No valid hardware definitions found in folder Mosquino.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/optiboot-v5.0/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/optiboot-v5.0/examples. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/optiboot-v5.0
  No valid hardware definitions found in folder optiboot-v5.0.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/sanguino/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/sanguino/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/sanguino/firmwares. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/sanguino/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/sanguino
  No valid hardware definitions found in folder sanguino.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/SDLogger/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/SDLogger/cores. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/SDLogger
  No valid hardware definitions found in folder SDLogger.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/tiny/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/tiny/cores. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/tiny
  No valid hardware definitions found in folder tiny.
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/wildFire/bootloaders. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/wildFire/cores. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/wildFire/firmwares. Is it pre-1.5?
Could not find boards.txt in /Users/**..**/Dropbox/Arduino/hardware/wildFire/variants. Is it pre-1.5?
WARNING: Error loading hardware folder /Users/**..**/Dropbox/Arduino/hardware/wildFire
  No valid hardware definitions found in folder wildFire.
java.lang.NumberFormatException: For input string: "version 2013-07-07-17:51"
 at java.lang.NumberFormatException.forInputString(NumberFormatException.java:65)
 at java.lang.Integer.parseInt(Integer.java:580)
 at java.lang.Integer.valueOf(Integer.java:766)
 at cc.arduino.contributions.VersionHelper.valueOf(VersionHelper.java:16)
 at cc.arduino.contributions.packages.DownloadableContribution.getParsedVersion(DownloadableContribution.java:97)
 at cc.arduino.contributions.libraries.LibrariesIndexer.scanLibrary(LibrariesIndexer.java:160)
 at cc.arduino.contributions.libraries.LibrariesIndexer.scanInstalledLibraries(LibrariesIndexer.java:122)
 at cc.arduino.contributions.libraries.LibrariesIndexer.rescanLibraries(LibrariesIndexer.java:102)
 at cc.arduino.contributions.libraries.LibrariesIndexer.setLibrariesFolders(LibrariesIndexer.java:90)
 at processing.app.BaseNoGui.onBoardOrPortChange(BaseNoGui.java:749)
 at processing.app.Base.onBoardOrPortChange(Base.java:1126)
 at processing.app.Base$10.actionPerformed(Base.java:1283)
 at processing.app.Base.rebuildBoardsMenu(Base.java:1259)
 at processing.app.Base.<init>(Base.java:258)
 at processing.app.Base.guardedMain(Base.java:198)
 at processing.app.Base.main(Base.java:113)
logout

Look like it doesn’t like my boards (^_^)

There is a library with version "version 2013-07-07-17:51" which is incorrect syntax. A fix has just been pushed and it's available in the nightly builds http://arduino.cc/en/Main/Software#nightly
If you wish to stick with 1.6.3, please locate the library with the "strange" version and change it to something more common, like 1.1.0

awesome thank you!!!!!

nightly builds works fine for me thanks !