Arduino IDE 2.0.0-beta.5 available for download!

A new release of Arduino IDE 2.x is now available for download here:

https://www.arduino.cc/en/software#experimental-software

This release has some significant improvements and bug fixes. That work was assisted by valuable feedback from Arduino community members. Thanks!

If you have any questions or feedback please post here in the IDE 2.x’s dedicated forum category:

https://forum.arduino.cc/c/software/arduino-ide-2-0-beta/93

If you want to see the list of known issues, work in progress, submit a formal report, or contribute to development, the IDE 2.x source code is hosted in this public repository:

https://github.com/arduino/arduino-ide

Notable changes

  • Improve resiliency and feedback in the event of system errors (0d0ad9e, f106c97, 26a1db3)
  • Improved feedback during installation via Boards Manager and Library Manager (9aff90b, c20f832)
  • Update to Arduino CLI 0.18.1 (8071298)
  • Use currently selected board when opening a new sketch (c86d82d)
  • Automatically open new files of the open sketch when they are added externally (fa9334e)
  • Make Sketch > Show Sketch Folder open the correct folder (c50d45c)
  • Show libraries and examples even when no board is selected (cb2ef78, 68af4c3)
  • Suppress irrelevant “An unexpected error occurred when locating the Git executable” on startup (a8df244)
  • Eliminate unnecessary empty space in debug hover (80bddc2)
  • Remove minimum window dimensions limit (4e7f829)
  • Eliminate GLIBCXX_3.4.26 dependency on Linux (26a1db3)
  • Allow AsciiDoc and Markdown documentation files to be opened as sketch tabs (b17b7a6)
  • Add keymaps customization support via File > Advanced > Keyboard Shortcuts (562b77a)
  • Update debugger version to 0.3.10 (cdd5cfd)
1 Like

suggestion … separate arduino folder and library folder … my favorites folder in c:\users\luigi\appdata\arduino\libreries…

no in folder c:\users\luigi\documents\arduino\

Possible suggestion.
Thanks,

Try downloading the ATT tiny 85 board on 2.0 beta 5 and was unable to burn the boot loader. Software stated that the boot loader process was completed successfully yet I was unable to use the Arduino as an ISP. Not changing the wiring I then tried the old Arduino 1.83 and it worked as predicted

I installed this version and it will not run, attached is a screenshot of the terminal. Using Linux Mint 17.1

Hi @markf442. My guess is that this problem is caused by the outdated operating system version you are using.

Haha, it’s “only” 6 years old and otherwise works fine. Not worth the trouble upgrading and having to fix everything that breaks and reinstalling half my programs. I’ll try it on my laptop. Thanks.

1 Like

When I run the app it just sits there with the logo screen and background with spinning dots, doesn’t get any further (have arduino-cli installed), macOS 11.3

Hi folks,
installed Beta5 for 2 weeks now, and did not use old 1.8 version since that :sunglasses:

Especially I liked the "typo" marking, although if I made a large number of bugs in a project, it doesn't keep up of all of them at once :sunglasses:

I think this version is very good for beta, and some minor problems aside, quite well already.

Thanks to all for your effort.

2 Likes

I thought I saw the answer somewhere but cannot find it. I just want to verify: I can install 2.0 beta and it will not affect the existing 1.8.13 in any way?

p.s. Ralph Bacon kicks the tires: #211 Like Arnie, I'm back! 😃 Arduino IDE 2.0 (Beta) - YouTube

That’s the way previous versions worked :thinking:

Thanks. Just looking for that warm and fuzzy feeling before I download.

The installation will not affect the other. However, by default they do share the same sketchbook folder and data folder where the Boards Manager installations are stored. So library or boards installations you make in one will affect the other. In general, that is the preferred behavior. It is possible to isolate each from the other though, and I can provide instructions for that if you want them.

Thanks! I didn't want to lose my hard-won dark color scheme!

You're welcome. And please don't allow my assurances to dissuade you from backing up any irreplaceable data. Arduino IDE 2.0.0 is still in the beta development phase, which means "expect the unexpected".

You might be disappointed to discover that Arduino IDE 2.0.0 does not support the classic Arduino IDE's themes. However, as consolation you'll find that there are two built-in dark themes available in File > Preferences. Because Arduino IDE 2.0.0 is built on a compatible framework, VS Code themes should be usable, which has the potential to provide a huge number of custom themes:
https://marketplace.visualstudio.com/search?target=VSCode&category=Themes&sortBy=Installs

However, fair warning that there is currently no official support or documentation for installing custom themes. Maybe you'll find that one of the four default themes meets all your requirements.

No disappointment there.

Actually, the Dark(Theia) colors are pretty close to the custom theme I'm using now.

Two main bugs I've noticed using v2.0.0-beta:

  1. the pop-up info when hovering over code is annoying but useful. Annoying because it covers up the code you are pointing to. Maybe have it over not over the code but to the right? Otherwise its very useful (so worthwhile keeping as a feature)

  2. this version wont open a second file by clicking on the file. I have to open using the file menu from an open session. Would be more convenient to open by clicking on a file. Currently to conveniently open a second file, I have to open it in the existing stable version.

Overall, great new version, with a few tweaks it will be pretty awesome!

Hi @bi-labs. Thanks for giving the Arduino IDE 2.x beta a try and providing your valuable feedback!

This bug is being tracked here:

Work is in progress now to resolve this deficiency:

This topic was automatically closed 120 days after the last reply. New replies are no longer allowed.