Arduino IDE 2.0 beta won't install

Hello!
I have downloaded the beta version and tried to install it in my secondary drive. It didn't like that so I then went to install normally, but the default location still shows my secondary drive. I've tried manually typing in C://Program Files and then C://Users/name and even tried C://Users/name/AppData/Local, but none of them would work. It just starts the install process and stops with the indicator bar about a third of the way across and says "Setup was not completed successfully".

Does anyone have any idea how to fix this? I would really like to use the new IDE.

Thank you in advance for you help.
Ron.

Hi @jsmwrench. If you use the "Windows ZIP file" download option to download Arduino IDE 2.x from the arduino.cc "Sofware" page then you can simply unzip the downloaded file to any convenient location on your computer. There is no installation process when using this "Windows ZIP file" version of the IDE. Just run the Arduino IDE.exe file you find in the unzipped folder and the IDE will start up.

I appreciate the response and suggestion. I will give it a try. Thank you again!!

That worked perfectly! Thank you much.