Arduino IDE and ESET: Slow compilation

Hello, dear Arduino community,

Recently, I bought a new laptop: ASUS K56CB, i7 2,5GHz, 6GB RAM, 64bit Windows 8, and installed Arduino 1.0.5-r2 with Windows installer. Also, I have an anti-virus program - ESET NOD32 Anivirus 7. The problem is, that when I try to compile my sketch, it takes about 2-3min to compile it (even simple Blink example takes that much) and the compilation status bar stucks at the middle. I did some research and found out, that when I start compilation, in Task Manager ESET Service takes about 30% of CPU and after compilation, it came back to normal - about 0,3% of CPU.

So, has anybody faced this kind of problem? I really need to fix it. Any help would be appreciated. Thanks in advance!

Anyone? Need help.

Hello I have the same problem. I used Ad-Ware as anti-virus, if I shot it off when I compile, it's help but it still slower then before. I read in some section of this forum that it could be also due to the Bluetooth connection. Something in the IDE is shared with it. I'm looking for something more efficient then turn in ON and OFF my Antivirus. Any solution or path to it, is welcome

I'm using IDE ver 1.0.5r2. Arduino UNO My OS is win 7

Thank you :) MadKart

Had the same problem. Here is how I solved it.

In ESET, in the Setup tab, click on HIPS and choose configure. Uncheck "Enable HIPS" and click OK. Reboot your computer.

This fixed the problem for me. A sketch that was taking 2 minutes or more to compile now compiles in 2 seconds.

Hi,

no need to fully disable HIPS, just create the right rule like this :

Then enjoy compiling !

Thanks Overcrash, for a helpful posting. Now my Win8 machine compiles without hesitation :)

Now I must investigate why my Vista machine with the same AV (ESET NOD32 Antivirus (8.0.304.1) apparently does not need the HIPS rule for compilation to run smoothly...