Arduino IDE crashes on Verify/Compile (tried all the fixes already)

A couple of days ago my arduino IDE just started to exit out of the program every time I try and compile any sketch, even examples. It seems to have started around the time I installed eclipse (making a GUI for my arduino) and a Java JRE. So besides all of the other fixes on google I also tried uninstalling eclipse, installing other versions of the JRE, uninstalling all versions of the JRE then trying each JDK and JRE. I even tried getting the JRE 6 and replacing the arduino java files with that I've tried just about everything I can think of and nothing works. I even uninstalled arduino 1.0.5 and tried older versions and still no luck. I am running windows 7 64-bit on an alienware m17x, dual GTX 280M graphics and an intel core 2 duo t9800 cpu. Also, it did start happening after I enabled the pcie gen 2 in the bios settings then I disabled it because I saw no results from it. If anyone has any suggestions I will gladly take them