Arduino IDE error while compiling, help !

Hello, few days ago I bought a SparkFun Blynk board and I decided to try programming it with the Arduino IDE but it gives me this error:

Arduino: 1.6.9 (Windows 10), Board: "SparkFun Blynk Board, 80 MHz, Serial, 921600, 4M (1M SPIFFS)"

Board sparkfunBlynk (platform esp8266, package esp8266) is unknown

Error compiling for board SparkFun Blynk Board.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

I have installed the FTDI drivers as well as the SparkFun Blynk board support for Arduino IDE.

Arduino: 1.6.9 (Windows 10), Board: "SparkFun Blynk Board, 80 MHz, Serial, 921600, 4M (1M SPIFFS)"

C:\Program Files (x86)\Arduino\arduino-builder -dump-prefs -logger=machine -hardware "C:\Program Files (x86)\Arduino\hardware" -hardware "C:\Users\miroslav\AppData\Local\Arduino15\packages" -tools "C:\Program Files (x86)\Arduino\tools-builder" -tools "C:\Program Files (x86)\Arduino\hardware\tools\avr" -tools "C:\Users\miroslav\AppData\Local\Arduino15\packages" -built-in-libraries "C:\Program Files (x86)\Arduino\libraries" -libraries "C:\Users\miroslav\Documents\Arduino\libraries" -fqbn=esp8266:esp8266:sparkfunBlynk:CpuFrequency=80,UploadTool=esptool,UploadSpeed=921600,FlashSize=4M1M -ide-version=10609 -build-path "C:\Users\miroslav\AppData\Local\Temp\buildf61f26ea0129d5d9cbc2ae8797b03a57.tmp" -warnings=none -prefs=build.warn_data_percentage=75 -verbose "C:\Users\miroslav\Documents\Arduino\sketch_jul22c\sketch_jul22c.ino"

Board sparkfunBlynk (platform esp8266, package esp8266) is unknown

Error compiling for board SparkFun Blynk Board.

Same error with "Show verbose output during" compilation enabled.

Board sparkfunBlynk (platform esp8266, package esp8266) is unknown

You are trying to compile for a board that you have not downloaded, or properly installed, the required package for.

I can't imagine how to make that message any clearer.

PaulS:
You are trying to compile for a board that you have not downloaded, or properly installed, the required package for.

I can't imagine how to make that message any clearer.

I'm having the same trouble, but however clear you say the message is, I'm not sure what to do with the info.. I have installed the package for the board that is "unknown", which is why I'm able to pick the board type from the pulldown. I can't find anything else that says I should be doing anything differently.

I have uninstalled completely and reinstalled current versions freshly downloaded..

Any way to tell why this isn't working? I can't even get a simple "blink' sketch to compile..

FWIW, mine is with the Sparkfun 8266 thing devboard..

I suspect you need to get advice from Sparkfun - assuming they created the data files for their board.

...R

Hi,

I've had a SparkFun ESP8266 Thing Dev for about 6 months and have been programming it with the Arduino IDE with no problems, until I downloaded and installed a board update (using the IDE update) yesterday.

Now I'm getting:

Arduino: 1.6.11 (Windows 10), Board: "SparkFun ESP8266 Thing Dev, 80 MHz, 115200"

Board thingdev (platform esp8266, package esp8266) is unknown

Error compiling for board SparkFun ESP8266 Thing Dev.

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.

It seems that the update is not good and causing the problem. Is there any way to roll back?

Hello user support:

I contacted SparkFun Tech support, they say this is an error in the IDE of Arduino?
Identical to the post from Karma 120 days ago

** Arduino IDE appears to not work when the user switches boards files i.e. (NodeMCU and the SparkFun Blynk Board)

The issue was not resolved rather to contact SparkFun
Advise (from SparkFin) was to uninstall Arduino and and install the Blynk lib again…same results

I have used Node MCU with similar problems, but after upgrading the ESP8266 boards it finally works

When I insert the Sparkfun Blynk Board (json) file into preferences, I am able to select the board via brd mgr

The problem Arduino is does not recognize the SparkBlynk board?

MAC-OS Yosemite
FTDI driver installed
Arduino 1.8.5
Blynk release 5.0 Libs

** attached sketch_feb18a.ino

error report:
Arduino: 1.8.5 (Mac OS X), Board: “SparkFun Blynk Board, 80 MHz, Serial, 115200, 4M (1M SPIFFS)”

Board sparkfunBlynk (platform esp8266, package esp8266) is unknown

Error compiling for board SparkFun Blynk Board.

Any suggestions from User support?

Thanks for your time.

sketch_feb18a.ino (2.17 KB)

Hi. Were you able to find an answer? I'm facing the same issue.

Thanks~