Arduino IDE Freeze when File Open/Save dialog displayed - Win 10

I was running this ok a while back however now; I can run Arduino IDE (Was 1.8.0 now updated to 1.8.2) but when doing a file-open the dialog shows (and includes content of the docs/arduino folder) but this is locked, cant move/cancel/select/drag. Right-click the Arduino toolbar icon and close does nothing, I have to go to task manager and kill the Java RTE.

The app still works otherwise, compiling and publishing to cards and serial/about windows display and work ok too.

So I think it may have been along the Win 10 Creators update timeline but also may be a driver change issue. I am running a Dell 9550 with a 4k screen (on an nvidia card) so some items (like the splash screen and dialog icons) are small) but its always worked before.

I tried upgrading/reinstalling the app, fully uninstalling and installing the base app again but no change. I tried updating the java include within the app to a newer version, again no change to the problem.

Thanks for any suggestions.

Have you tried using the regular IDE and not the app.

Some people have reported issues with the APP version.

Thanks for the tip, I am not sure what you mean by just the IDE and not the app, isnt the arduino app the programming service to upload to devices? Is there an option? ← I am limited in experience with this.

I have been using this with the additional support for the ESP8266 so I do need this (I think) for the various libraries and add-ins to work fully (for me).

Also what reported issues with the APP? I have been searching and found no equivalent items with a similar problem (except in Ubuntu) or something 5 years ago referring to video drivers, so is this bigger than I am aware?

Always learning…

There is an “APP” for windows 10

An there are then the IDE’s in either ZIP format or INSTALLER format.

Then of course there is the ONLINE IDE called CREATE EDITOR.

The best by far is the INSTALLER version currently 1.8.2.

IDE selection 02.jpg

Ah, Windows store app, didnt even consider going there, am downloading that now to try.

Yes, also had a quick look at the online system. Still figuring that and also how to add the extended modules required for 8266 support.

Thanks, will let you know how the app goes.

The Windows Store App appears to work well, thanks for the advice. Dialogs are opening and working as expected.

Still yet to try compiling and usb/serial support because... I have found however that http://arduino.esp8266.com/stable/package_esp8266com_index.json is currently offline and a few people are asking without a clear answer to this problem... investigating.

Ooops. sorry spoke too soon.

Same issue has returned and I think it occurred after the 8266 json file and board was added. Now I cant remove them so working on it.

The online editor does not support the ESP’s yet despite it being on a lot of peoples wish list including mine.

What you see is what you got as far as board selection. Although it does support clones right out of the starting gate.

Thanks again for that info.

Yeah, the site at arduino.esp8266.com is currently experiencing a dns issue so this may take some time. It seems this board add-on (json) causes the problem I am seeing, either internally somewhere or because it is defaulting/pointing to an alternative directory on load. Until the dns issue get fixed I cant confirm other than using an alternative one somebody has setup for now.

Arg, ok I will take this over to esp8266.com as I have now confirmed the issue (at least for me) is localised to that add-in.

Thanks for helping, Rex.

Just a quick update, FYI.
arduino.esp8266.com is back and working again so i was able to re-load the libraries and board options and get this sorted.

For me, once the 8266 board was added doing a file open or save directed this to my docs/customproject folder and each time locked up there. I could not find in prefs or prefs.txt any reference to this so I moved customproject into /docs/arduino/customproject
Next time I tried an open the app went back to the default folder /docs/arduino and worked ok, I could even then navigate into customproject and load up my old code with no problems.

So my greatest appreciation to Ballscrewbob for his help and guidance.