Arduino IDE not starting (Windows)

When I try to open the Arduino IDE, it shows the splash screen but stops after that without any error.
"arduino.exe" shows up in the task manager for a brief moment but dissapears again.
I found many "solutions" for this problem, but none of them work.

I'm using Windows 7 ultimate (64bit) sp1, Java version 1.7.0_51 and arduino-1.0.5-r2.

I already tried the following things:

-removing and reinstalling the latest Java version.
-removing and reinstalling the latest Arduino IDE
(The standalone version used to work. I tried both the installer and the standalone version but none of them work)
-Running arduino.exe from the command line with "--l4j-debug".
(It doesn't create the log file, so I'm not sure what I'm doing wrong here)
-Running arduino.exe as an administrator in compatibility mode and/or with visual themes disabled.
-Installing the Arduino Enhanced Release 1.0.5 for Windows.
(Same problem as with the regular version)
-removing java and arduino IDE, running Ccleaner to clean up the registry and some files, reinstalling java and the IDE.

So it probably is a problem with Java, but I can't figure out what I'm doing wrong. Any ideas?

Try the suggestion of renaming the data file it worked for me For info on the solution.

launch4j error corrected | Making Things Interact Fall 09?

It involved renaming the data file.

There have been so many people having this issue, I wonder why the compiler isn't fixed. Is this a bug in the compiler

I can't seem to find the arduino data folder, I guess it's not there because the IDE didn't make one yet.
Also, I don't get any errors (launch4j in this case) so I don't think it will fix my problem.