Arduino IDE on Raspberry Pi Screens to large for display.

I am running the Arduino IDE on a Raspberry PI with a 1024x600 screen.
The settings screen is too big and the OK button is out of reach.
Would it be possible to fix that?
Regards
Laszlo

The same problem exists in x86 linux (Ubuntu) on displays with 600 pixel height.

Here's the relevant issue report:

Note that it's considered solved. I think the developers decided they had done as much as they could to support small displays and were not interested in working on it further.

The workaround mentioned is to hide the taskbar. Another workaround would be to change preferences by editing preferences.txt in a text editor, which allows you to change all the preferences you find in File > Preferences, as well as some extra options. The location of preferences.txt can be found by clicking the link at the line following File > Preferences > More preferences can be edited directly in the file. If you can't see that, then it should be in /home/{username}/.arduino15 (AKA ~/.arduino15).

I forgot to say that you need to exit the Arduino IDE before you edit preferences.txt.

AFAIK (which isn’t very far, actually), the “task bar” on a lot of unix window managers doesn’t have a “hide” feature… :frowning:

In PIXEL (the desktop environment commonly used on RPi), if you select "Panel Settings" from the taskbar's context menu and then select the "Advanced" tab, you can set it to "Minimize panel when not in use". Then it will only pop up when you hover the mouse pointer over the bottom 2 pixels (adjustable). You can also set the taskbar to be on the left, right, or top of the screen in the "Geometry" tab.

pert:
In PIXEL (the desktop environment commonly used on RPi), if you select “Panel Settings” from the taskbar’s context menu and then select the “Advanced” tab, you can set it to “Minimize panel when not in use”. Then it will only pop up when you hover the mouse pointer over the bottom 2 pixels (adjustable). You can also set the taskbar to be on the left, right, or top of the screen in the “Geometry” tab.

I already have the panel on the left. despite of that I can’t see the OK of the settings.

Workaround: I place the cusor on the last accessible field and enter 3 tabs. It works, but it is dirty.
Why not having placed a slider?

RIN67630's issue report:

I suspect the addition of the Theme preference since the time of the previous work to support small screens might have lead to the Preferences window size increasing. I don't know anything about the IDE's code so I don't understand the limitations the developers are working under. It seems odd that there is still the large empty space between the last text on the Preferences window and the buttons.

I'm sure the Arduino developers would be happy to give consideration to any pull requests that address this problem.