Arduino IDE running in Mint LINUX Mint 18.2 (Sonya) not uploading to Uno r3

I have my Arduino IDE 2:1.0 installed in Mint LINUX 18.2. In the tools menu, it shows my Arduino Uno r3 connected to /dev/ttyACM0. When I run dmesg, it also shows there is an Arduino board connected and shows it connected to /dev/ttyACM0. When I attempt to upload the "Blink" code to test everything out, I get the following error:

System wide configuration file is "/usr/share/arduino/hardware/tools/avrdude.conf"
         User configuration file is "/home/karl/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : usb
         Using Programmer              : stk500v2
avrdude: usbdev_open(): did not find any USB device "usb" (0x03eb:0x2104)

avrdude done.  Thank you.

I have found no info on how to set this up. I have read the troubleshooting info on Arduino Playground, to no avail. Please help. Thank you in advance for your help.

Are you selecting Upload Using Programmer? If so, try just hitting the Upload Arrow after making sure you have the correct port selected.

I get the same error on IDE 1.8.5 Linux Mint 18.3 when using Upload Using Programmer with Tools/Programmer: "AVRISP mkII" selected

Probably unrelated to your problem, but note that the Arduino IDE you get from the package manager (e.g. apt-get install arduino) is modified and outdated. You should always use the official Arduino IDE downloaded from http://www.arduino.cc/en/Main/Software.